summaryrefslogtreecommitdiff
path: root/media-gfx/ristretto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
commit39fcd539b9eeb7df75bccad136265b5f001d1a3c (patch)
treefcedf7eec512b29edce8c642c52f834b2e15b4f8 /media-gfx/ristretto
parentb982051e7c8e12c3810a0d21d30d687b406b3ae5 (diff)
gentoo auto-resync : 16:12:2022 - 15:36:37
Diffstat (limited to 'media-gfx/ristretto')
-rw-r--r--media-gfx/ristretto/Manifest2
-rw-r--r--media-gfx/ristretto/ristretto-0.12.4.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/ristretto/Manifest b/media-gfx/ristretto/Manifest
index fc04f30b3ed0..df609cce4a9a 100644
--- a/media-gfx/ristretto/Manifest
+++ b/media-gfx/ristretto/Manifest
@@ -1,3 +1,5 @@
DIST ristretto-0.12.3.tar.bz2 616251 BLAKE2B 0f64918bae8511259acc90ce8851be0067ce635416fa908fde5a1e1fe9ae895b18cda06505c82cfae0aaf89fce41a56f80d5c2bcd4ad6cd3e93a95ef5cfb9037 SHA512 c78ec55196fbf3bcb843b240faea1f7eb532bfdc519c125337ebb61d20ab8e01c818920c9ec1bdd97035f8b5ce9bcd2ffb338a91b8919ca48ab1010828a8d49d
+DIST ristretto-0.12.4.tar.bz2 619084 BLAKE2B c04d09b8475a46e89a2151cc46121ec9960f52ba8e861c474a46a8bda470c6620dfe2c38a35a80c075d830b7d4d3b80c435ebe1baf10bb913e20d26945d1701c SHA512 666e127646b9f30bed54d8605c4892d302b15dff39e8b532ebb3da22dc5700414e6d7bcb29d8d66f6a8a7d487cff50b0a0cc610d8b4616479397ebf987ff409b
EBUILD ristretto-0.12.3.ebuild 899 BLAKE2B 22909ebbf5a641d6b26ccc1e3595a388086bb0dfd981d565cf042868a96c2e816dee6f5420b2549ed06401e6e5822b5070ea6e30f595e66c61e97c0ec4c81fb4 SHA512 e171f72e986df77de173def2b98fad78bd7c8f504a82ff956eea1da6dd849ea2add21d073e12ffdbc460570c0939c4b594d249bbfe98da9ba306c81786c1e8c0
+EBUILD ristretto-0.12.4.ebuild 901 BLAKE2B f548c4907d62833114a2e44748215638314af5e639315143993a52514407aaa78c3423c0166bb84db1c6decb0d1f953a585691ab736e07a2bba2ee8a4a98302a SHA512 ed069e6213458941ca0f7f042bd49eed7600bb398678fdbc6b82e3b1db76d2e973be935062e5aaed1f181cda1d3b1362ac9481286e4f8731966c30f31622ed4d
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/media-gfx/ristretto/ristretto-0.12.4.ebuild b/media-gfx/ristretto/ristretto-0.12.4.ebuild
new file mode 100644
index 000000000000..869d4e7f337b
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.12.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A fast and lightweight picture viewer for Xfce"
+HOMEPAGE="https://docs.xfce.org/apps/ristretto/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ media-libs/libexif:0=
+ sys-apps/file
+ x11-libs/cairo:0
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.16:0=
+ >=xfce-base/libxfce4util-4.16:0=
+ >=xfce-base/xfconf-4.12.1:0=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}