summaryrefslogtreecommitdiff
path: root/media-gfx/quat/quat-1.20-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 09:35:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 09:35:57 +0000
commitb982051e7c8e12c3810a0d21d30d687b406b3ae5 (patch)
tree1f40c63a302b92f633c075f289851ab62633babe /media-gfx/quat/quat-1.20-r3.ebuild
parentb62381b18b4bf2e919cbfbae11ebcad391e38e77 (diff)
gentoo auto-resync : 16:12:2022 - 09:35:57
Diffstat (limited to 'media-gfx/quat/quat-1.20-r3.ebuild')
-rw-r--r--media-gfx/quat/quat-1.20-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/quat/quat-1.20-r3.ebuild b/media-gfx/quat/quat-1.20-r3.ebuild
new file mode 100644
index 000000000000..f959b5ad2329
--- /dev/null
+++ b/media-gfx/quat/quat-1.20-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A 3D quaternionic fractal generator"
+HOMEPAGE="http://www.physcip.uni-stuttgart.de/phy11733/quat_e.html"
+SRC_URI="http://www.physcip.uni-stuttgart.de/phy11733/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X debug"
+
+DEPEND="
+ >=sys-libs/zlib-1.1.4
+ X? (
+ =x11-libs/fltk-1*
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-build-for-clang16.patch" )
+
+src_configure() {
+ # throws tons of warnings otherwise
+ append-cxxflags -Wno-deprecated-declarations -Wno-writable-strings
+ export FLUID="/usr/bin/fluid" # needed because configure tries an invalid option
+ econf \
+ $(use_enable X gui) \
+ $(use_enable debug) \
+ $(use_enable debug prof)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}