summaryrefslogtreecommitdiff
path: root/media-gfx/qrencode/qrencode-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /media-gfx/qrencode/qrencode-4.1.1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'media-gfx/qrencode/qrencode-4.1.1.ebuild')
-rw-r--r--media-gfx/qrencode/qrencode-4.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/qrencode/qrencode-4.1.1.ebuild b/media-gfx/qrencode/qrencode-4.1.1.ebuild
new file mode 100644
index 000000000000..0872a1336274
--- /dev/null
+++ b/media-gfx/qrencode/qrencode-4.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C library for encoding data in a QR Code symbol"
+HOMEPAGE="https://fukuchi.org/works/qrencode/"
+SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_with test tests)
+ # TODO: figure out how to make SDL check fail as the SDL test
+ # program is not useful
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ cd tests || die
+ ./test_basic.sh || die
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}