summaryrefslogtreecommitdiff
path: root/media-gfx/qrencode/qrencode-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/qrencode/qrencode-4.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/qrencode/qrencode-4.0.0.ebuild')
-rw-r--r--media-gfx/qrencode/qrencode-4.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/qrencode/qrencode-4.0.0.ebuild b/media-gfx/qrencode/qrencode-4.0.0.ebuild
new file mode 100644
index 000000000000..76deeee294d2
--- /dev/null
+++ b/media-gfx/qrencode/qrencode-4.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="C library for encoding data in a QR Code symbol"
+HOMEPAGE="https://fukuchi.org/works/qrencode/"
+SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_with test tests)
+ # TODO: figure out how to make SDL check fail as the SDL test
+ # program is not useful
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ cd tests || die
+ # the configure test checks if reconfiguring works...
+ sed -i -e '/configure/d' test_all.sh || die
+ sh test_all.sh || die
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}