summaryrefslogtreecommitdiff
path: root/media-gfx/prusaslicer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-01 17:41:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-01 17:41:24 +0000
commit5d5b0e27ed33330cca5636eb792368fbbf46774c (patch)
tree9df5f4721779bac4fe92c830c1c5d2786f274b88 /media-gfx/prusaslicer/files
parentfd1824e9b1fd180f410170bf2d02e1f098f53db9 (diff)
gentoo auto-resync : 01:03:2024 - 17:41:24
Diffstat (limited to 'media-gfx/prusaslicer/files')
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.5.0_alpha2-boost-fixes.patch93
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.5.0_boost-1.81-std-wxString-to-std-wstring.patch40
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-cereal-1.3.1.patch48
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-fix-tests.patch14
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.5.2-fix-slicing.patch76
5 files changed, 0 insertions, 271 deletions
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_alpha2-boost-fixes.patch b/media-gfx/prusaslicer/files/prusaslicer-2.5.0_alpha2-boost-fixes.patch
deleted file mode 100644
index 9418707c1065..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_alpha2-boost-fixes.patch
+++ /dev/null
@@ -1,93 +0,0 @@
---- a/src/hints/HintsToPot.cpp
-+++ b/src/hints/HintsToPot.cpp
-@@ -1,6 +1,7 @@
- #include <iostream>
- #include <vector>
- #include <string>
-+#include <boost/nowide/fstream.hpp>
- #include <boost/filesystem.hpp>
- #include <boost/dll.hpp>
- #include <boost/property_tree/ini_parser.hpp>
-@@ -9,7 +10,7 @@
-
- bool write_to_pot(boost::filesystem::path path, const std::vector<std::pair<std::string, std::string>>& data)
- {
-- boost::filesystem::ofstream file(std::move(path), std::ios_base::app);
-+ boost::nowide::ofstream file(std::move(path), std::ios_base::app);
- for (const auto& element : data)
- {
- //Example of .pot element
---- a/src/libslic3r/Preset.cpp
-+++ b/src/libslic3r/Preset.cpp
-@@ -25,6 +25,7 @@
- #include <stdexcept>
- #include <unordered_map>
- #include <boost/format.hpp>
-+#include <boost/nowide/fstream.hpp>
- #include <boost/filesystem.hpp>
- #include <boost/filesystem/fstream.hpp>
- #include <boost/algorithm/string.hpp>
-@@ -84,7 +85,7 @@ ConfigFileType guess_config_file_type(const ptree &tree)
- VendorProfile VendorProfile::from_ini(const boost::filesystem::path &path, bool load_all)
- {
- ptree tree;
-- boost::filesystem::ifstream ifs(path);
-+ boost::nowide::ifstream ifs(path);
- boost::property_tree::read_ini(ifs, tree);
- return VendorProfile::from_ini(tree, path, load_all);
- }
---- a/src/slic3r/GUI/DesktopIntegrationDialog.cpp
-+++ b/src/slic3r/GUI/DesktopIntegrationDialog.cpp
-@@ -10,6 +10,7 @@
- #include "libslic3r/Platform.hpp"
- #include "libslic3r/Config.hpp"
-
-+#include <boost/nowide/fstream.hpp>
- #include <boost/filesystem.hpp>
- #include <boost/log/trivial.hpp>
- #include <boost/dll/runtime_symbol_info.hpp>
-@@ -503,4 +504,4 @@ DesktopIntegrationDialog::~DesktopIntegrationDialog()
-
- } // namespace GUI
- } // namespace Slic3r
--#endif // __linux__
-\ No newline at end of file
-+#endif // __linux__
---- a/src/slic3r/GUI/GUI_App.cpp
-+++ b/src/slic3r/GUI/GUI_App.cpp
-@@ -13,6 +13,7 @@
- #include <cstdlib>
- #include <regex>
- #include <string_view>
-+#include <boost/nowide/fstream.hpp>
- #include <boost/algorithm/string/predicate.hpp>
- #include <boost/algorithm/string.hpp>
- #include <boost/format.hpp>
---- a/src/slic3r/GUI/HintNotification.cpp
-+++ b/src/slic3r/GUI/HintNotification.cpp
-@@ -15,6 +15,7 @@
- #include "libslic3r/PrintConfig.hpp"
-
- #include <boost/algorithm/string/replace.hpp>
-+#include <boost/nowide/fstream.hpp>
- #include <boost/filesystem.hpp>
- #include <boost/nowide/fstream.hpp>
- #include <boost/log/trivial.hpp>
-@@ -65,7 +66,7 @@ inline void push_style_color(ImGuiCol idx, const ImVec4& col, bool fading_out, f
-
- void write_used_binary(const std::vector<std::string>& ids)
- {
-- boost::filesystem::ofstream file((boost::filesystem::path(data_dir()) / "cache" / "hints.cereal"), std::ios::binary);
-+ boost::nowide::ofstream file((boost::filesystem::path(data_dir()) / "cache" / "hints.cereal"), std::ios::binary);
- cereal::BinaryOutputArchive archive(file);
- HintsCerealData cd { ids };
- try
-@@ -84,7 +85,7 @@ void read_used_binary(std::vector<std::string>& ids)
- BOOST_LOG_TRIVIAL(warning) << "Failed to load to hints.cereal. File does not exists. " << path.string();
- return;
- }
-- boost::filesystem::ifstream file(path);
-+ boost::nowide::ifstream file(path);
- cereal::BinaryInputArchive archive(file);
- HintsCerealData cd;
- try
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_boost-1.81-std-wxString-to-std-wstring.patch b/media-gfx/prusaslicer/files/prusaslicer-2.5.0_boost-1.81-std-wxString-to-std-wstring.patch
deleted file mode 100644
index becab0a88355..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_boost-1.81-std-wxString-to-std-wstring.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/src/slic3r/GUI/PrintHostDialogs.cpp
-+++ b/src/slic3r/GUI/PrintHostDialogs.cpp
-@@ -79,8 +79,8 @@ PrintHostSendDialog::PrintHostSendDialog
- if (size_t extension_start = recent_path.find_last_of('.'); extension_start != std::string::npos)
- m_valid_suffix = recent_path.substr(extension_start);
- // .gcode suffix control
-- auto validate_path = [this](const wxString &path) -> bool {
-- if (! path.Lower().EndsWith(m_valid_suffix.Lower())) {
-+ auto validate_path = [this](const std::wstring &path) -> bool {
-+ if (! wxString(path).Lower().EndsWith(m_valid_suffix.Lower())) {
- MessageDialog msg_wingow(this, wxString::Format(_L("Upload filename doesn't end with \"%s\". Do you wish to continue?"), m_valid_suffix), wxString(SLIC3R_APP_NAME), wxYES | wxNO);
- if (msg_wingow.ShowModal() == wxID_NO)
- return false;
-@@ -90,7 +90,7 @@ PrintHostSendDialog::PrintHostSendDialog
-
- auto* btn_ok = add_button(wxID_OK, true, _L("Upload"));
- btn_ok->Bind(wxEVT_BUTTON, [this, validate_path](wxCommandEvent&) {
-- if (validate_path(txt_filename->GetValue())) {
-+ if (validate_path(txt_filename->GetValue().ToStdWstring())) {
- post_upload_action = PrintHostPostUploadAction::None;
- EndDialog(wxID_OK);
- }
-@@ -100,7 +100,7 @@ PrintHostSendDialog::PrintHostSendDialog
- if (post_actions.has(PrintHostPostUploadAction::StartPrint)) {
- auto* btn_print = add_button(wxID_YES, false, _L("Upload and Print"));
- btn_print->Bind(wxEVT_BUTTON, [this, validate_path](wxCommandEvent&) {
-- if (validate_path(txt_filename->GetValue())) {
-+ if (validate_path(txt_filename->GetValue().ToStdWstring())) {
- post_upload_action = PrintHostPostUploadAction::StartPrint;
- EndDialog(wxID_OK);
- }
-@@ -111,7 +111,7 @@ PrintHostSendDialog::PrintHostSendDialog
- // Using wxID_MORE as a button identifier to be different from the other buttons, wxID_MORE has no other meaning here.
- auto* btn_simulate = add_button(wxID_MORE, false, _L("Upload and Simulate"));
- btn_simulate->Bind(wxEVT_BUTTON, [this, validate_path](wxCommandEvent&) {
-- if (validate_path(txt_filename->GetValue())) {
-+ if (validate_path(txt_filename->GetValue().ToStdWstring())) {
- post_upload_action = PrintHostPostUploadAction::StartSimulation;
- EndDialog(wxID_OK);
- }
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-cereal-1.3.1.patch b/media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-cereal-1.3.1.patch
deleted file mode 100644
index 056c6150a7b0..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-cereal-1.3.1.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -127,7 +127,7 @@
- set_target_properties(PrusaSlicer PROPERTIES OUTPUT_NAME "prusa-slicer")
- endif ()
-
--target_link_libraries(PrusaSlicer libslic3r cereal)
-+target_link_libraries(PrusaSlicer libslic3r libcereal)
-
- if (APPLE)
- # add_compile_options(-stdlib=libc++)
---- a/src/slic3r/CMakeLists.txt
-+++ b/src/slic3r/CMakeLists.txt
-@@ -260,7 +260,7 @@
-
- encoding_check(libslic3r_gui)
-
--target_link_libraries(libslic3r_gui libslic3r avrdude cereal imgui GLEW::GLEW OpenGL::GL hidapi libcurl ${wxWidgets_LIBRARIES})
-+target_link_libraries(libslic3r_gui libslic3r avrdude libcereal imgui GLEW::GLEW OpenGL::GL hidapi libcurl ${wxWidgets_LIBRARIES})
-
- if (MSVC)
- target_link_libraries(libslic3r_gui Setupapi.lib)
---- a/src/libslic3r/CMakeLists.txt
-+++ b/src/libslic3r/CMakeLists.txt
-@@ -395,7 +395,7 @@
- target_link_libraries(libslic3r
- libnest2d
- admesh
-- cereal
-+ libcereal
- libigl
- miniz
- boost_libs
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -446,6 +446,12 @@
-
- # Find the Cereal serialization library
- find_package(cereal REQUIRED)
-+add_library(libcereal INTERFACE)
-+if (NOT TARGET cereal::cereal)
-+ target_link_libraries(libcereal INTERFACE cereal)
-+else()
-+ target_link_libraries(libcereal INTERFACE cereal::cereal)
-+endif()
-
- # l10n
- set(L10N_DIR "${SLIC3R_RESOURCES_DIR}/localization")
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-fix-tests.patch b/media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-fix-tests.patch
deleted file mode 100644
index c86c585926ab..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.5.0_rc1-fix-tests.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/tests/fff_print/test_data.cpp
-+++ b/tests/fff_print/test_data.cpp
-@@ -4,10 +4,9 @@
- #include "libslic3r/GCodeReader.hpp"
- #include "libslic3r/Config.hpp"
- #include "libslic3r/Print.hpp"
--#include "libslic3r/Format/OBJ.hpp"
--#include "libslic3r/Format/STL.hpp"
-
- #include <cstdlib>
-+#include <fstream>
- #include <string>
-
- #include <boost/nowide/cstdio.hpp>
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.5.2-fix-slicing.patch b/media-gfx/prusaslicer/files/prusaslicer-2.5.2-fix-slicing.patch
deleted file mode 100644
index ae85057f10bd..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.5.2-fix-slicing.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --git a/src/libslic3r/GCode.cpp b/src/libslic3r/GCode.cpp
-index f8fc2e5a7..c74ee32dd 100644
---- a/src/libslic3r/GCode.cpp
-+++ b/src/libslic3r/GCode.cpp
-@@ -1551,27 +1551,27 @@ void GCode::process_layers(
- }
- });
- const auto spiral_vase = tbb::make_filter<LayerResult, LayerResult>(slic3r_tbb_filtermode::serial_in_order,
-- [&spiral_vase = *this->m_spiral_vase](LayerResult in) -> LayerResult {
-+ [spiral_vase = this->m_spiral_vase.get()](LayerResult in) -> LayerResult {
- if (in.nop_layer_result)
- return in;
-
-- spiral_vase.enable(in.spiral_vase_enable);
-- return { spiral_vase.process_layer(std::move(in.gcode)), in.layer_id, in.spiral_vase_enable, in.cooling_buffer_flush};
-+ spiral_vase->enable(in.spiral_vase_enable);
-+ return { spiral_vase->process_layer(std::move(in.gcode)), in.layer_id, in.spiral_vase_enable, in.cooling_buffer_flush};
- });
- const auto pressure_equalizer = tbb::make_filter<LayerResult, LayerResult>(slic3r_tbb_filtermode::serial_in_order,
-- [&pressure_equalizer = *this->m_pressure_equalizer](LayerResult in) -> LayerResult {
-- return pressure_equalizer.process_layer(std::move(in));
-+ [pressure_equalizer = this->m_pressure_equalizer.get()](LayerResult in) -> LayerResult {
-+ return pressure_equalizer->process_layer(std::move(in));
- });
- const auto cooling = tbb::make_filter<LayerResult, std::string>(slic3r_tbb_filtermode::serial_in_order,
-- [&cooling_buffer = *this->m_cooling_buffer](LayerResult in) -> std::string {
-+ [cooling_buffer = this->m_cooling_buffer.get()](LayerResult in) -> std::string {
- if (in.nop_layer_result)
- return in.gcode;
-
-- return cooling_buffer.process_layer(std::move(in.gcode), in.layer_id, in.cooling_buffer_flush);
-+ return cooling_buffer->process_layer(std::move(in.gcode), in.layer_id, in.cooling_buffer_flush);
- });
- const auto find_replace = tbb::make_filter<std::string, std::string>(slic3r_tbb_filtermode::serial_in_order,
-- [&self = *this->m_find_replace](std::string s) -> std::string {
-- return self.process_layer(std::move(s));
-+ [find_replace = this->m_find_replace.get()](std::string s) -> std::string {
-+ return find_replace->process_layer(std::move(s));
- });
- const auto output = tbb::make_filter<std::string, void>(slic3r_tbb_filtermode::serial_in_order,
- [&output_stream](std::string s) { output_stream.write(s); }
-@@ -1633,25 +1633,25 @@ void GCode::process_layers(
- }
- });
- const auto spiral_vase = tbb::make_filter<LayerResult, LayerResult>(slic3r_tbb_filtermode::serial_in_order,
-- [&spiral_vase = *this->m_spiral_vase](LayerResult in)->LayerResult {
-+ [spiral_vase = this->m_spiral_vase.get()](LayerResult in)->LayerResult {
- if (in.nop_layer_result)
- return in;
-- spiral_vase.enable(in.spiral_vase_enable);
-- return { spiral_vase.process_layer(std::move(in.gcode)), in.layer_id, in.spiral_vase_enable, in.cooling_buffer_flush };
-+ spiral_vase->enable(in.spiral_vase_enable);
-+ return { spiral_vase->process_layer(std::move(in.gcode)), in.layer_id, in.spiral_vase_enable, in.cooling_buffer_flush };
- });
- const auto pressure_equalizer = tbb::make_filter<LayerResult, LayerResult>(slic3r_tbb_filtermode::serial_in_order,
-- [&pressure_equalizer = *this->m_pressure_equalizer](LayerResult in) -> LayerResult {
-- return pressure_equalizer.process_layer(std::move(in));
-+ [pressure_equalizer = this->m_pressure_equalizer.get()](LayerResult in) -> LayerResult {
-+ return pressure_equalizer->process_layer(std::move(in));
- });
- const auto cooling = tbb::make_filter<LayerResult, std::string>(slic3r_tbb_filtermode::serial_in_order,
-- [&cooling_buffer = *this->m_cooling_buffer](LayerResult in)->std::string {
-+ [cooling_buffer = this->m_cooling_buffer.get()](LayerResult in)->std::string {
- if (in.nop_layer_result)
- return in.gcode;
-- return cooling_buffer.process_layer(std::move(in.gcode), in.layer_id, in.cooling_buffer_flush);
-+ return cooling_buffer->process_layer(std::move(in.gcode), in.layer_id, in.cooling_buffer_flush);
- });
- const auto find_replace = tbb::make_filter<std::string, std::string>(slic3r_tbb_filtermode::serial_in_order,
-- [&self = *this->m_find_replace](std::string s) -> std::string {
-- return self.process_layer(std::move(s));
-+ [find_replace = this->m_find_replace.get()](std::string s) -> std::string {
-+ return find_replace->process_layer(std::move(s));
- });
- const auto output = tbb::make_filter<std::string, void>(slic3r_tbb_filtermode::serial_in_order,
- [&output_stream](std::string s) { output_stream.write(s); }