summaryrefslogtreecommitdiff
path: root/media-gfx/povray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/povray
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/povray')
-rw-r--r--media-gfx/povray/Manifest1
-rw-r--r--media-gfx/povray/povray-3.7.0.0-r2.ebuild143
2 files changed, 144 insertions, 0 deletions
diff --git a/media-gfx/povray/Manifest b/media-gfx/povray/Manifest
index f2ebdc8d779c..dca2cb9869df 100644
--- a/media-gfx/povray/Manifest
+++ b/media-gfx/povray/Manifest
@@ -6,4 +6,5 @@ AUX povray-3.7.0_rc6-darwin-defaults.patch 920 BLAKE2B 9cffcda18626cfdbea9a6b00a
DIST povray-3.7.0.0.tar.gz 38191521 BLAKE2B 5d936bdcdf9910ede2247cfa5e3881211da00762ac4bc08225dc6b53addc9e09546de9493e642b5d41228d81a50a4bcfbb5e606eb8bd9a224bb1afc5fc82db6e SHA512 82e3dbcd58b7ae921fe3b953815ca4dbbfb22eda434554baee4accabd1455b18cb511061f1cf9cf93128fab0a042df374fe2f68186d78c19853a465bd4bcbe10
DIST povray-3.7.0.0_p20160914-fix-c++14.patch.bz2 12876 BLAKE2B b1c458764f04a57420a4562e9faacae4ae955c3d9ce4343ffd49176bb575f63830fcd58d0777dea22b975df118aa14e2bdd91509758d33d659daa3fbbaba5880 SHA512 3329da12a822762559445e208a746ff208c39f7b63e27ba84a390074bb52a105c9a2f66180e58c5157795bb16346e11b5b05efaf077ee0d8246179975a692b04
EBUILD povray-3.7.0.0-r1.ebuild 4583 BLAKE2B 0c44090841e9a6b22b4c9b89c161bbfbe0e4bd080e49a6d0bcbc14a177a565a5b45984661b66b428af3070e714eaca1e7d4c15c28e86ef44b76cee487ab46736 SHA512 e9ae09577410ecb5dc6f3eb68dae1e231fa118b180a6c737b612d6827c7e9c3cdcdb48a30b59e715265d142cc00992b4adf095bcfddd7d2a91e041b24312fec2
+EBUILD povray-3.7.0.0-r2.ebuild 4538 BLAKE2B 52ff4018c1a2be0c5d73fda678dc386bfc78ea6182795dcba9264a58b1b0eae006864681834afea21319f75dbbf83c90719c01e866c14af2eb5a7a0b2366995b SHA512 6c9f4e2b65abc4ae2b6134bf52ae4e4a13ecc289c9838338688f9d5f99e59018556ffecff1b33dd1dc2bd13f8994fc077ea5b92f5543aabb83f16a6704bc78aa
MISC metadata.xml 410 BLAKE2B e2d166cc7ed5872c7e0bdcf69c7856bd8218b059e9b0444a68930216c423ef7c8922ad963cfc3dc56f0d997c1a6372a04058815eb2b36487d07dbc6752908e2d SHA512 c159e2c730bba95d7c65525d62af05bd5b9d873a519e734010a8e5bc597590147accfe02e23946f0349c0be31a10b3e578d035bc3ff8d11a11274c1957a834be
diff --git a/media-gfx/povray/povray-3.7.0.0-r2.ebuild b/media-gfx/povray/povray-3.7.0.0-r2.ebuild
new file mode 100644
index 000000000000..89abce251e24
--- /dev/null
+++ b/media-gfx/povray/povray-3.7.0.0-r2.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic versionator virtualx
+
+POVRAY_MAJOR_VER=$(get_version_component_range 1-3)
+POVRAY_MINOR_VER=$(get_version_component_range 4)
+if [ -n "$POVRAY_MINOR_VER" ]; then
+ POVRAY_MINOR_VER=${POVRAY_MINOR_VER/rc/RC}
+ MY_PV="${POVRAY_MAJOR_VER}.${POVRAY_MINOR_VER}"
+else
+ MY_PV=${POVRAY_MAJOR_VER}
+fi
+
+DESCRIPTION="The Persistence of Vision Raytracer"
+HOMEPAGE="https://www.povray.org/"
+SRC_URI="https://github.com/POV-Ray/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${P}_p20160914-fix-c++14.patch.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug +io-restrictions tiff X"
+
+DEPEND="
+ >=dev-libs/boost-1.50.0:=[threads(+)]
+ media-libs/libpng:0
+ sys-libs/zlib
+ virtual/jpeg:0
+ tiff? ( media-libs/tiff:0 )
+ X? ( media-libs/libsdl )"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ sys-devel/autoconf-archive"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-user-conf.patch
+ "${FILESDIR}"/${P}-automagic.patch
+ "${WORKDIR}"/${P}_p20160914-fix-c++14.patch
+ "${FILESDIR}"/${P}-gcc6-openexr.patch
+)
+
+src_prepare() {
+ [[ ${CHOST} == *-darwin* ]] && \
+ PATCHES+=( "${FILESDIR}"/${PN}-3.7.0_rc6-darwin-defaults.patch )
+ eapply "${FILESDIR}"/${P}-r1-boost-1.50.patch
+
+ pushd unix &>/dev/null || die
+ pushd config &>/dev/null || die
+ rm -rf \
+ acx_pthread.m4 \
+ ax_boost_base.m4 \
+ ax_boost_thread.m4 \
+ ax_compare_version.m4 \
+ ax_compiler_vendor.m4 \
+ ax_compiler_version.m4 || die
+ popd &>/dev/null || die
+ bash -x prebuild.sh || die
+ popd &>/dev/null || die
+
+ rm -rf libraries || die
+
+ # Change some directories that cannot be adjusted via configure
+ sed \
+ -e 's:${povsysconfdir}/$PACKAGE/$VERSION_BASE:${povsysconfdir}/'${PN}':g' \
+ -e 's:${povdatadir}/$PACKAGE-$VERSION_BASE:${povdatadir}/'${PN}':g' \
+ -e 's:${povdatadir}/doc/$PACKAGE-$VERSION_BASE:${povdatadir}/doc/'${PF}':g' \
+ -e 's:BOOST_THREAD_LIBS $LIBS:BOOST_THREAD_LIBS $LIBS -lboost_date_time:g' \
+ -e 's:"/usr/include":"'${EPREFIX}'/usr/include":' \
+ -e 's:"/usr/lib":"'${EPREFIX}'/usr/'$(get_libdir)'":' \
+ -i configure.ac || die
+
+ sed \
+ -e "s:^povlibdir = .*:povlibdir = @datadir@/${PN}:" \
+ -e "s:^povdocdir = .*:povdocdir = @datadir@/doc/${PF}:" \
+ -e "s:^povconfdir = .*:povconfdir = @sysconfdir@/${PN}:" \
+ -e 's:mkdir_p:MKDIR_P:g' \
+ -i Makefile.am || die
+
+ # The "+p" option on the test command line causes a pause and
+ # prompts the user to interact, so remove it.
+ sed -i -e "s:biscuit.pov -f +d +p:biscuit.pov -f +d:" Makefile.am || die
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Fixes bug 71255
+ if [[ $(get-flag march) == k6-2 ]]; then
+ filter-flags -fomit-frame-pointer
+ fi
+
+ # The config files are installed correctly (e.g. povray.conf),
+ # but the code compiles using incorrect [default] paths
+ # (based on /usr/local...), so povray will not find the system
+ # config files without the following fix:
+ append-cppflags -DPOVLIBDIR=\\\"${EROOT}usr/share/${PN}\\\" -DPOVCONFDIR=\\\"${EROOT}etc/${PN}\\\"
+
+ # TODO: Restore OpenEXR if upstream start to support OpenEXR 3/imath
+ econf \
+ COMPILED_BY="Portage (Gentoo $(uname)) on $(hostname -f)" \
+ $(use_enable debug) \
+ $(use_enable io-restrictions) \
+ --without-openexr \
+ $(use_with tiff libtiff "${EPREFIX}/usr/$(get_libdir)") \
+ $(use_with X libsdl "${EPREFIX}/usr/$(get_libdir)") \
+ $(use_with X x "${EPREFIX}/usr/$(get_libdir)") \
+ $(usex tiff "" "NON_REDISTRIBUTABLE_BUILD=yes") \
+ --with-boost-libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --without-libmkl \
+ --disable-pipe \
+ --disable-static \
+ --disable-strip \
+ --disable-optimiz \
+ --disable-optimiz-arch
+}
+
+src_test() {
+ virtx default
+}
+
+pkg_preinst() {
+ # Copy the old config files if they are in the old location
+ # but do not yet exist in the new location.
+ # This way, they can be treated by CONFIG_PROTECT as normal.
+ local conf_file version_dir
+ for conf_file in "${ED}"/etc/"${PN}"/*; do
+ if [ ! -e "${EROOT}etc/${PN}/${conf_file}" ]; then
+ for version_dir in $(echo "${EROOT}"etc/"${PN}"/* | grep "^[0-9]" | sort -rn); do
+ if [ -e "${EROOT}etc/${PN}/${version_dir}/${conf_file}" ]; then
+ mv "${EROOT}etc/${PN}/${version_dir}/${conf_file}" "${EROOT}etc/${PN}" || die
+ elog "Note: ${conf_file} moved from ${EROOT}etc/povray/${version_dir}/ to ${EROOT}etc/povray/"
+ break
+ fi
+ done
+ fi
+ done
+}