summaryrefslogtreecommitdiff
path: root/media-gfx/pngtools/pngtools-0.4_p20220314.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-05 07:05:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-05 07:05:51 +0000
commit66a7d60eb8beba754ba79c2752cbf70fcf741b0b (patch)
treeba0fa0ac1410fd921f6c30cffbebda88ac06f61e /media-gfx/pngtools/pngtools-0.4_p20220314.ebuild
parent5c6b55db727bab81f5c3625597b29583c30186a3 (diff)
gentoo auto-resync : 05:03:2024 - 07:05:50
Diffstat (limited to 'media-gfx/pngtools/pngtools-0.4_p20220314.ebuild')
-rw-r--r--media-gfx/pngtools/pngtools-0.4_p20220314.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-gfx/pngtools/pngtools-0.4_p20220314.ebuild b/media-gfx/pngtools/pngtools-0.4_p20220314.ebuild
index 0e411a64e826..67bd84dbf9e8 100644
--- a/media-gfx/pngtools/pngtools-0.4_p20220314.ebuild
+++ b/media-gfx/pngtools/pngtools-0.4_p20220314.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
MY_COMMIT="1ccca3a0f3f6882661bbafbfb62feb774ca195d1"
DESCRIPTION="A series of tools for the PNG image format"
@@ -30,6 +30,15 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/875371
+ # https://github.com/mikalstill/pngtools/issues/21
+ filter-lto
+
+ default
+}
+
src_install() {
default