summaryrefslogtreecommitdiff
path: root/media-gfx/plantuml/plantuml-8046.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/plantuml/plantuml-8046.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/plantuml/plantuml-8046.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-8046.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/plantuml/plantuml-8046.ebuild b/media-gfx/plantuml/plantuml-8046.ebuild
new file mode 100644
index 000000000000..e214cf19d516
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-8046.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="http://plantuml.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+
+RDEPEND=">=virtual/jre-1.7
+ dev-java/ant-core:0
+ >=media-gfx/graphviz-2.26.3"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+}