summaryrefslogtreecommitdiff
path: root/media-gfx/plantuml/plantuml-1.2022.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 08:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 08:47:16 +0100
commit7405d8a728a9553d7b8eccb67737c5193c9f13ba (patch)
treeb724a0d3f660dce5eb1a6a7aedb3e83f983c4dfd /media-gfx/plantuml/plantuml-1.2022.7.ebuild
parent2d51a70c0ec989cfc28d2d9a140206a601378c58 (diff)
gentoo auto-resync : 24:08:2022 - 08:47:15
Diffstat (limited to 'media-gfx/plantuml/plantuml-1.2022.7.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-1.2022.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/plantuml/plantuml-1.2022.7.ebuild b/media-gfx/plantuml/plantuml-1.2022.7.ebuild
new file mode 100644
index 000000000000..c1ad0e0aaa4f
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2022.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="https://plantuml.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ dev-java/ant-core:0
+ media-gfx/graphviz"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+
+ make_desktop_entry plantuml PlantUML
+}