summaryrefslogtreecommitdiff
path: root/media-gfx/photoqt/photoqt-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
commit1cfea2a84c51291a77ab820b6871efcff10c148d (patch)
tree924f8b07cb24ba72b3d889cf4b50bdff4d2785c0 /media-gfx/photoqt/photoqt-2.9.1.ebuild
parent441369caa3d11703d0349d4b9746b7ad10aa6cb2 (diff)
gentoo auto-resync : 07:11:2022 - 21:22:53
Diffstat (limited to 'media-gfx/photoqt/photoqt-2.9.1.ebuild')
-rw-r--r--media-gfx/photoqt/photoqt-2.9.1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/media-gfx/photoqt/photoqt-2.9.1.ebuild b/media-gfx/photoqt/photoqt-2.9.1.ebuild
deleted file mode 100644
index f73af804f930..000000000000
--- a/media-gfx/photoqt/photoqt-2.9.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_KDEINSTALLDIRS=false
-inherit ecm optfeature
-
-DESCRIPTION="Simple but powerful Qt-based image viewer"
-HOMEPAGE="https://photoqt.org/"
-SRC_URI="https://photoqt.org/pkgs/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="devil exif freeimage graphicsmagick imagemagick mpv pdf raw"
-
-COMMON_DEPEND="
- app-arch/libarchive:=
- app-arch/unrar
- dev-libs/pugixml
- dev-qt/qtdbus:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5[jpeg]
- dev-qt/qtimageformats:5
- dev-qt/qtmultimedia:5[qml]
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- devil? ( media-libs/devil )
- exif? ( media-gfx/exiv2:= )
- freeimage? ( media-libs/freeimage )
- imagemagick? (
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- )
- mpv? ( media-video/mpv[libmpv] )
- pdf? ( app-text/poppler[qt5] )
- raw? ( media-libs/libraw:= )
-"
-DEPEND="${COMMON_DEPEND}
- dev-qt/qtconcurrent:5
-"
-RDEPEND="${COMMON_DEPEND}
- dev-qt/qtgraphicaleffects:5
- dev-qt/qtquickcontrols:5
- dev-qt/qtquickcontrols2:5
-"
-BDEPEND="dev-qt/linguist-tools:5"
-
-src_configure() {
- local mycmakeargs=(
- -DCHROMECAST=OFF # TODO needs python
- -DDEVIL=$(usex devil)
- -DEXIV2=$(usex exif)
- -DFREEIMAGE=$(usex freeimage)
- -DGRAPHICSMAGICK=$(usex graphicsmagick $(usex imagemagick))
- -DIMAGEMAGICK=$(usex imagemagick $(usex !graphicsmagick))
- -DVIDEO_MPV=$(usex mpv)
- -DPOPPLER=$(usex pdf)
- -DRAW=$(usex raw)
- )
- ecm_src_configure
-}
-
-pkg_postinst() {
- optfeature "additional image formats like AVIF, EPS, HEIF/HEIC, PSD, etc." kde-frameworks/kimageformats
- ecm_pkg_postinst
-}