summaryrefslogtreecommitdiff
path: root/media-gfx/photoqt/photoqt-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /media-gfx/photoqt/photoqt-1.7.1.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'media-gfx/photoqt/photoqt-1.7.1.ebuild')
-rw-r--r--media-gfx/photoqt/photoqt-1.7.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/photoqt/photoqt-1.7.1.ebuild b/media-gfx/photoqt/photoqt-1.7.1.ebuild
new file mode 100644
index 000000000000..b1e9fd011dee
--- /dev/null
+++ b/media-gfx/photoqt/photoqt-1.7.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="Simple but powerful Qt-based image viewer"
+HOMEPAGE="https://photoqt.org/"
+SRC_URI="https://photoqt.org/pkgs/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devil exiv2 freeimage graphicsmagick pdf raw"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtimageformats:5
+ dev-qt/qtmultimedia:5[qml]
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ app-arch/libarchive:=
+ app-arch/unrar
+ devil? ( media-libs/devil )
+ exiv2? ( media-gfx/exiv2:= )
+ freeimage? ( media-libs/freeimage )
+ graphicsmagick? ( >=media-gfx/graphicsmagick-1.3.20:= )
+ pdf? ( app-text/poppler[qt5] )
+ raw? ( media-libs/libraw:= )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEVIL=$(usex devil)
+ -DEXIV2=$(usex exiv2)
+ -DFREEIMAGE=$(usex freeimage)
+ -DGM=$(usex graphicsmagick)
+ -DPOPPLER=$(usex pdf)
+ -DRAW=$(usex raw)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}