summaryrefslogtreecommitdiff
path: root/media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-09 01:31:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-09 01:31:00 +0100
commitc956c264bdc853972b72016b752683468881af25 (patch)
treed6305ce3422074c4aaf3159ddd7a23bba7682e45 /media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild
parent541eca7cf7b9950f0adaaf9158f94c76ba0aedc9 (diff)
gentoo auto-resync : 09:10:2022 - 01:31:00
Diffstat (limited to 'media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild')
-rw-r--r--media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild b/media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..c103f0e2eb16
--- /dev/null
+++ b/media-gfx/pdf2svg/pdf2svg-0.2.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Convert PDF to SVG files using poppler and cairo"
+HOMEPAGE="https://www.cityinthesky.co.uk/opensource/pdf2svg/ https://github.com/dawbarton/pdf2svg/"
+SRC_URI="https://github.com/dawbarton/pdf2svg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=app-text/poppler-0.12.3-r3[cairo]
+ >=x11-libs/cairo-1.2.6:=[svg(+)]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ) # ChangeLog is only for <=0.2.1
+# and README.md doesn't have anything useful for usage
+
+src_prepare() {
+ sed -i \
+ -e 's:#include <stdio.h>:#include <stdio.h>\n#include <stdlib.h>:' \
+ ${PN}.c || die
+ default
+}