summaryrefslogtreecommitdiff
path: root/media-gfx/openvdb/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /media-gfx/openvdb/files
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'media-gfx/openvdb/files')
-rw-r--r--media-gfx/openvdb/files/openvdb-8.0.1-add-consistency-for-NumPy-find_package-call.patch21
-rw-r--r--media-gfx/openvdb/files/openvdb-8.1.0-glfw-libdir.patch21
-rw-r--r--media-gfx/openvdb/files/openvdb-9.0.0-numpy.patch151
3 files changed, 193 insertions, 0 deletions
diff --git a/media-gfx/openvdb/files/openvdb-8.0.1-add-consistency-for-NumPy-find_package-call.patch b/media-gfx/openvdb/files/openvdb-8.0.1-add-consistency-for-NumPy-find_package-call.patch
new file mode 100644
index 000000000000..87d1d24755b4
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-8.0.1-add-consistency-for-NumPy-find_package-call.patch
@@ -0,0 +1,21 @@
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Thu, 28 Oct 2021 11:34:16 +0200
+Subject: [PATCH] add consistency for NumPy find_package call
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+
+diff --git a/openvdb/openvdb/python/CMakeLists.txt b/openvdb/openvdb/python/CMakeLists.txt
+index b473beb..b468d4f 100644
+--- a/openvdb/openvdb/python/CMakeLists.txt
++++ b/openvdb/openvdb/python/CMakeLists.txt
+@@ -94,7 +94,7 @@ else()
+ OPENVDB_CHECK_PYTHON_VERSION(${Python_VERSION} ${Python_INCLUDE_DIRS})
+
+ if(USE_NUMPY)
+- find_package(Python QUIET COMPONENTS NumPy)
++ find_package(Python QUIET COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS} NumPy)
+ if(NOT TARGET Python::NumPy)
+ message(FATAL_ERROR "Could NOT find NumPy (Required is at least version "
+ "\"${MINIMUM_NUMPY_VERSION}\")"
+--
+2.33.1
diff --git a/media-gfx/openvdb/files/openvdb-8.1.0-glfw-libdir.patch b/media-gfx/openvdb/files/openvdb-8.1.0-glfw-libdir.patch
new file mode 100644
index 000000000000..412785fb0e14
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-8.1.0-glfw-libdir.patch
@@ -0,0 +1,21 @@
+Custom cmake file used to find GLFW always looks at lib/cmake first
+ignoring alternate libdirs and leads to using wrong libraries.
+
+https://bugs.gentoo.org/800200
+[rebased by sam]
+--- a/cmake/OpenVDBGLFW3Setup.cmake
++++ b/cmake/OpenVDBGLFW3Setup.cmake
+@@ -83,10 +83,10 @@ endif()
+
+ list(APPEND _GLFW3_ROOT_SEARCH_DIR ${SYSTEM_LIBRARY_PATHS})
+
+-set(_GLFW3_PATH_SUFFIXES "lib/cmake/glfw3" "cmake/glfw3" "glfw3")
++set(_GLFW3_PATH_SUFFIXES "cmake/glfw3" "glfw3")
+
+ # GLFW 3.1 installs CMake modules into glfw instead of glfw3
+-list(APPEND _GLFW3_PATH_SUFFIXES "lib/cmake/glfw" "cmake/glfw" "glfw")
++list(APPEND _GLFW3_PATH_SUFFIXES "cmake/glfw" "glfw")
+
+ find_path(GLFW3_CMAKE_LOCATION glfw3Config.cmake
+ ${_FIND_GLFW3_ADDITIONAL_OPTIONS}
+
diff --git a/media-gfx/openvdb/files/openvdb-9.0.0-numpy.patch b/media-gfx/openvdb/files/openvdb-9.0.0-numpy.patch
new file mode 100644
index 000000000000..972db42b3556
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-9.0.0-numpy.patch
@@ -0,0 +1,151 @@
+Grabbed relevant parts from upstream PR for 9.x; it's a variant
+of https://github.com/gentoo/gentoo/pull/22738 which wa sfor earlier versions.
+
+https://github.com/AcademySoftwareFoundation/openvdb/pull/1237
+
+From 3c5f69efeacca762406a80d74b39b970c7023bd6 Mon Sep 17 00:00:00 2001
+From: Nick Avramoussis <4256455+Idclip@users.noreply.github.com>
+Date: Thu, 28 Oct 2021 16:54:10 +0100
+Subject: [PATCH 1/3] Improvements to find_package Python usage. Primarily
+ fixes an issues where NumPy needs to be specified along with the Development
+ and Interpreter components in a single call
+
+Signed-off-by: Nick Avramoussis <4256455+Idclip@users.noreply.github.com>
+---
+ openvdb/openvdb/python/CMakeLists.txt | 97 +++++++++++++--------------
+ 1 file changed, 46 insertions(+), 51 deletions(-)
+
+diff --git a/openvdb/openvdb/python/CMakeLists.txt b/openvdb/openvdb/python/CMakeLists.txt
+index 7b36379f9..5e9141e8c 100644
+--- a/openvdb/openvdb/python/CMakeLists.txt
++++ b/openvdb/openvdb/python/CMakeLists.txt
+@@ -55,25 +55,39 @@ endif()
+ # be provided to find_package(Python) with differing major versions. e.g.
+ # calls to find_package(Python 2.7) fails if python3 is found on the system.
+ function(OPENVDB_CHECK_PYTHON_VERSION)
+- set(_PY_VERSION ${ARGV0})
+- set(_PY_PATH ${ARGV1})
+- if(NOT _PY_VERSION)
+- message(FATAL_ERROR "Could NOT find Python (Required is at least version "
+- "\"${MINIMUM_PYTHON_VERSION}\")"
+- )
+- elseif(_PY_VERSION VERSION_LESS MINIMUM_PYTHON_VERSION)
+- message(FATAL_ERROR "Could NOT find Python: Found unsuitable version \"${_PY_VERSION}\""
+- "but required is at least \"${MINIMUM_PYTHON_VERSION}\" (found ${_PY_PATH})"
+- )
+- else()
+- message(STATUS "Found Python: ${_PY_PATH}) (found suitable version \"${_PY_VERSION}\", "
+- "minimum required is \"${MINIMUM_PYTHON_VERSION}\")"
++ set(PY_TARGET ${ARGV0})
++ set(PY_TARGET_VERSION ${ARGV1})
++ set(PY_TARGET_INCLUDES ${ARGV2})
++ set(MIN_VERSION ${ARGV3})
++ set(FUTURE_MIN_VERSION ${ARGV4})
++
++ if(NOT TARGET ${PY_TARGET})
++ message(FATAL_ERROR "Could NOT find ${PY_TARGET} (Required is at least version "
++ "\"${MIN_VERSION}\")"
+ )
+ endif()
++
++ if(PY_TARGET_VERSION AND MIN_VERSION)
++ if(PY_TARGET_VERSION VERSION_LESS MIN_VERSION)
++ message(FATAL_ERROR "Could NOT find ${PY_TARGET}: Found unsuitable version "
++ "\"${PY_TARGET_VERSION}\" but required is at least \"${MIN_VERSION}\" (found ${PY_TARGET_INCLUDES})"
++ )
++ endif()
++ endif()
++
++ message(STATUS "Found ${PY_TARGET}: ${PY_TARGET_INCLUDES}) (found suitable "
++ "version \"${PY_TARGET_VERSION}\", minimum required is \"${MIN_VERSION}\")"
++ )
++
++ if(OPENVDB_FUTURE_DEPRECATION AND PY_TARGET_VERSION AND FUTURE_MIN_VERSION)
++ if(PY_TARGET_VERSION VERSION_LESS FUTURE_MIN_VERSION)
++ message(DEPRECATION "Support for ${PY_TARGET} versions < ${FUTURE_MIN_VERSION} "
++ "is deprecated and will be removed.")
++ endif()
++ endif()
+ endfunction()
+
+ # Configure Python and Numpy. Note that:
+-# - find_package(Python NumPy) requires CMake >= 3.14
+ # - find_package(Python Development) target Python::Module requires CMake >= 3.15
+ # - find_package(Python Development.Module) requires CMake >= 3.18
+ # To ensure consistent versions between components Interpreter, Compiler,
+@@ -85,38 +99,30 @@ endfunction()
+ set(OPENVDB_PYTHON_DEPS)
+ set(OPENVDB_PYTHON_REQUIRED_COMPONENTS Development)
+ if(NOT DEFINED PYOPENVDB_INSTALL_DIRECTORY)
+- list(APPEND OPENVDB_PYTHON_REQUIRED_COMPONENTS Interpreter)
++ list(APPEND OPENVDB_PYTHON_REQUIRED_COMPONENTS Interpreter)
+ endif()
+
+-find_package(Python QUIET COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS})
+-OPENVDB_CHECK_PYTHON_VERSION(${Python_VERSION} ${Python_INCLUDE_DIRS})
+-
+ if(USE_NUMPY)
+- find_package(Python QUIET COMPONENTS NumPy)
+- if(NOT TARGET Python::NumPy)
+- message(FATAL_ERROR "Could NOT find NumPy (Required is at least version "
+- "\"${MINIMUM_NUMPY_VERSION}\")"
+- )
+- elseif(Python_NumPy_VERSION VERSION_LESS MINIMUM_NUMPY_VERSION)
+- message(FATAL_ERROR "Could NOT find NumPy: Found unsuitable version \"${Python_NumPy_VERSION}\""
+- "but required is at least \"${MINIMUM_NUMPY_VERSION}\" (found ${Python_NumPy_INCLUDE_DIRS})"
+- )
+- else()
+- message(STATUS "Found NumPy: ${Python_NumPy_INCLUDE_DIRS} (found suitable "
+- "version \"${Python_NumPy_VERSION}\", minimum required is "
+- "\"${MINIMUM_NUMPY_VERSION}\")"
+- )
+- endif()
+- list(APPEND OPENVDB_PYTHON_DEPS Python::NumPy)
++ list(APPEND OPENVDB_PYTHON_REQUIRED_COMPONENTS NumPy)
+ endif()
+
++# Make sure find_package(Python) is only ever invoked once with all required components
++find_package(Python COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS})
++
++openvdb_check_python_version(Python::Module
++ "${Python_VERSION}"
++ "${Python_INCLUDE_DIRS}"
++ "${MINIMUM_PYTHON_VERSION}"
++ "${FUTURE_MINIMUM_PYTHON_VERSION}")
++list(APPEND OPENVDB_PYTHON_DEPS Python::Module)
++
+ if(USE_NUMPY)
+- if(OPENVDB_FUTURE_DEPRECATION AND FUTURE_MINIMUM_NUMPY_VERSION)
+- if(Python_NumPy_VERSION VERSION_LESS FUTURE_MINIMUM_NUMPY_VERSION)
+- message(DEPRECATION "Support for NumPy versions < ${FUTURE_MINIMUM_NUMPY_VERSION} "
+- "is deprecated and will be removed.")
+- endif()
+- endif()
++ openvdb_check_python_version(Python::NumPy
++ "${Python_NumPy_VERSION}"
++ "${Python_NumPy_INCLUDE_DIRS}"
++ "${MINIMUM_NUMPY_VERSION}"
++ "${FUTURE_MINIMUM_NUMPY_VERSION}")
++ list(APPEND OPENVDB_PYTHON_DEPS Python::NumPy)
+ endif()
+
+ if(TARGET openvdb_shared AND NOT Boost_USE_STATIC_LIBS)
+@@ -230,17 +236,6 @@ elseif(WIN32)
+ set_target_properties(pyopenvdb PROPERTIES SUFFIX ".pyd") # .pyd on windows
+ endif()
+
+-if(TARGET Python::Module)
+- list(APPEND OPENVDB_PYTHON_DEPS Python::Module)
+-else()
+- if(APPLE)
+- target_include_directories(pyopenvdb SYSTEM PUBLIC ${Python_INCLUDE_DIRS})
+- target_link_options(pyopenvdb PUBLIC -undefined dynamic_lookup)
+- else()
+- list(APPEND OPENVDB_PYTHON_DEPS Python::Python)
+- endif()
+-endif()
+-
+ target_link_libraries(pyopenvdb PUBLIC
+ ${OPENVDB_LIB}
+ ${OPENVDB_PYTHON_DEPS}
+