summaryrefslogtreecommitdiff
path: root/media-gfx/opentoonz/opentoonz-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /media-gfx/opentoonz/opentoonz-1.4.0.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'media-gfx/opentoonz/opentoonz-1.4.0.ebuild')
-rw-r--r--media-gfx/opentoonz/opentoonz-1.4.0.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/media-gfx/opentoonz/opentoonz-1.4.0.ebuild b/media-gfx/opentoonz/opentoonz-1.4.0.ebuild
new file mode 100644
index 000000000000..cccd2e4ca023
--- /dev/null
+++ b/media-gfx/opentoonz/opentoonz-1.4.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="An open-source full-featured 2D animation creation software"
+HOMEPAGE="https://github.com/opentoonz/opentoonz"
+SRC_URI="https://github.com/opentoonz/opentoonz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD libtiff"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-arch/lz4:=
+ >=dev-libs/boost-1.55.0:=
+ dev-libs/lzo:2
+ >=dev-qt/qtcore-5.9:5
+ >=dev-qt/qtgui-5.9:5
+ >=dev-qt/qtmultimedia-5.9:5[widgets]
+ >=dev-qt/qtnetwork-5.9:5
+ >=dev-qt/qtopengl-5.9:5
+ >=dev-qt/qtprintsupport-5.9:5
+ >=dev-qt/qtscript-5.9:5
+ >=dev-qt/qtsvg-5.9:5
+ >=dev-qt/qtwidgets-5.9:5
+ >=dev-qt/qtxml-5.9:5
+ media-libs/freeglut
+ media-libs/freetype:2
+ media-libs/glew:=
+ media-libs/libjpeg-turbo
+ >=media-libs/libmypaint-1.3.0:=
+ media-libs/libpng:=
+ >=sci-libs/superlu-4.1:=
+ sys-libs/zlib
+ virtual/cblas
+ virtual/libusb:1
+ virtual/opengl
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+CMAKE_USE_DIR="${S}"/toonz/sources
+CMAKE_MAKEFILE_GENERATOR=emake
+
+src_configure() {
+ local mycmakeargs=(
+ -DTIFF_LIBRARY="${S}/thirdparty/tiff-4.0.3/libtiff/.libs/libtiff.a"
+ -DSUPERLU_INCLUDE_DIR="${EPREFIX}/usr/include/superlu"
+ -DLZO_INCLUDE_DIR="${EPREFIX}/usr/include/lzo"
+ -DCMAKE_SKIP_RPATH=ON
+ )
+
+ # The upstream uses their own modified libtiff
+ # See: https://github.com/opentoonz/opentoonz/blob/master/doc/how_to_build_linux.md#building-libtiff
+ cd thirdparty/tiff-4.0.3 || die
+ econf \
+ --with-pic \
+ --disable-jbig \
+ --enable-static \
+ --disable-shared
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cd "${S}"/thirdparty/tiff-4.0.3 || die
+ emake
+
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}