summaryrefslogtreecommitdiff
path: root/media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch')
-rw-r--r--media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch b/media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch
new file mode 100644
index 000000000000..63a7a5bf75ed
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-2.0.1-r1-build-system.patch
@@ -0,0 +1,22 @@
+diff --git a/setup.py b/setup.py
+index 670df4d..703f9d2 100644
+--- a/setup.py
++++ b/setup.py
+@@ -471,9 +471,6 @@ class BuildExt (build_ext):
+ linkflags.extend([
+ "-O0",
+ ])
+- else:
+- linkflags.append("-O3")
+- ccflags.append("-O3")
+
+ return build_ext.build_extension(self, ext)
+
+@@ -869,7 +866,6 @@ def get_ext_modules():
+ '-Wno-write-strings',
+ '-D_POSIX_C_SOURCE=200809L',
+ "-DNO_TESTS", # FIXME: we're building against shared libmypaint now
+- '-g', # always include symbols, for profiling
+ ]
+ extra_link_args = []
+