summaryrefslogtreecommitdiff
path: root/media-gfx/metapixel/metapixel-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/metapixel/metapixel-1.0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/metapixel/metapixel-1.0.2-r1.ebuild')
-rw-r--r--media-gfx/metapixel/metapixel-1.0.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/metapixel/metapixel-1.0.2-r1.ebuild b/media-gfx/metapixel/metapixel-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..ac2b134a26c8
--- /dev/null
+++ b/media-gfx/metapixel/metapixel-1.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="a program for generating photomosaics"
+HOMEPAGE="http://www.complang.tuwien.ac.at/schani/metapixel"
+SRC_URI="http://www.complang.tuwien.ac.at/schani/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ >=media-libs/giflib-5:0=
+ >=media-libs/libpng-1.4:0=
+ virtual/jpeg:0
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libpng15.patch
+ "${FILESDIR}"/${P}-giflib5.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:/usr/X11R6:/usr:g' Makefile || die
+ sed -i -e 's:ar:$(AR):' rwimg/Makefile || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" LDOPTS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}{,-prepare,-imagesize,-sizesort}
+ doman ${PN}.1
+ dodoc NEWS README
+}