summaryrefslogtreecommitdiff
path: root/media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 01:09:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 01:09:44 +0000
commite33383d972aad8129fd4c1ee2b87f529f6efa8e9 (patch)
tree6a41fd6c2b9a997737264687637da3a9eee3d9d6 /media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild
parent89aeb05c8da1b0c32fb9d0cd5d202763780d5d5a (diff)
gentoo auto-resync : 24:11:2022 - 01:09:44
Diffstat (limited to 'media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild')
-rw-r--r--media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild b/media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..927de1cf02ef
--- /dev/null
+++ b/media-gfx/kxstitch/kxstitch-2.2.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.82.0
+QTMIN=5.15.5
+inherit ecm kde.org
+
+DESCRIPTION="Program to create cross stitch patterns"
+HOMEPAGE="https://apps.kde.org/kxstitch/ https://userbase.kde.org/KXStitch"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ media-gfx/imagemagick[cxx]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}/${P}-drop-xkeylock.patch"
+ "${FILESDIR}/${P}-fix-render-scaled-painter.patch"
+ "${FILESDIR}/${P}-fix-hidpi.patch"
+)