summaryrefslogtreecommitdiff
path: root/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
commit14a74a5f982f25582974c2ee235027a041aec36d (patch)
treedc57c37e535d9d67af9a5034c4748ec3698923b9 /media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
parentb1b0997aac1e7f68389ed3e0f95d3ea9d92277e2 (diff)
gentoo auto-resync : 25:11:2022 - 07:12:04
Diffstat (limited to 'media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild')
-rw-r--r--media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild b/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
index 8649717927b5..e036302e556a 100644
--- a/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
+++ b/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Prints information and tests integrity of JPEG/JFIF files"
HOMEPAGE="https://www.kokkonen.net/tjko/projects.html"
@@ -13,11 +13,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-RDEPEND="virtual/jpeg:0"
+RDEPEND="media-libs/libjpeg-turbo:="
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-1.6.0-parallel_install.patch )
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
src_configure() {
tc-export CC
econf