summaryrefslogtreecommitdiff
path: root/media-gfx/jp2a/jp2a-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
commitd5ee59790ee8298b8599b0aa0fa21a98b972a44d (patch)
tree2cc4393cdcfae28879cee110e5975f6e6b798f91 /media-gfx/jp2a/jp2a-1.2.0.ebuild
parentd855918b46ba8714cf1320fe63b55fd0ed1748a6 (diff)
gentoo auto-resync : 30:06:2024 - 08:00:50
Diffstat (limited to 'media-gfx/jp2a/jp2a-1.2.0.ebuild')
-rw-r--r--media-gfx/jp2a/jp2a-1.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/jp2a/jp2a-1.2.0.ebuild b/media-gfx/jp2a/jp2a-1.2.0.ebuild
new file mode 100644
index 000000000000..e3915d86ca7b
--- /dev/null
+++ b/media-gfx/jp2a/jp2a-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="JPEG/PNG image to ASCII art converter"
+HOMEPAGE="https://github.com/Talinx/jp2a/"
+SRC_URI="https://github.com/Talinx/jp2a/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+IUSE="curl"
+
+# TODO: restore ncurses support?
+# See https://github.com/gentoo/gentoo/pull/24218#issuecomment-1043795319
+RDEPEND="media-libs/libjpeg-turbo:=
+ media-libs/libpng
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable curl)
+}