summaryrefslogtreecommitdiff
path: root/media-gfx/jhead/files/Makefile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /media-gfx/jhead/files/Makefile
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'media-gfx/jhead/files/Makefile')
-rw-r--r--media-gfx/jhead/files/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/jhead/files/Makefile b/media-gfx/jhead/files/Makefile
new file mode 100644
index 000000000000..5f1d9799a42b
--- /dev/null
+++ b/media-gfx/jhead/files/Makefile
@@ -0,0 +1,44 @@
+#--------------------------------
+# jhead makefile for Unix
+# this make file also creates libjhead for meshlab
+#--------------------------------
+OBJ=.
+SRC=.
+AR = ar cqs
+LFLAGS = -shared -Wl,-soname,libjhead.so.1
+
+objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/jpgqguess.o $(OBJ)/paths.o \
+ $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
+
+TARGET = libjhead.so.1.0.0
+TARGET0 = libjhead.so
+TARGET1 = libjhead.so.1
+TARGET2 = libjhead.so.1.0
+
+all: jhead $(TARGET)
+
+$(OBJ)/%.o:$(SRC)/%.c
+ ${CC} -fPIC $(CFLAGS) -c $< -o $@
+
+jhead: $(objs) jhead.h
+ ${CC} ${LDFLAGS} -o jhead $(objs) -lm
+
+clean:
+ rm -f $(objs) jhead ${TARGET} ${TARGETA} ${TARGET0} ${TARGETD} \
+ ${TARGET1} ${TARGET2}
+
+install:
+ cp jhead ${DESTDIR}/usr/bin/
+ cp ${TARGET} ${DESTDIR}/usr/lib/
+ cp jhead ${DESTDIR}/usr/bin/
+ cp ${TARGET0} ${DESTDIR}/usr/lib/
+ cp ${TARGET1} ${DESTDIR}/usr/lib/
+ cp ${TARGET2} ${DESTDIR}/usr/lib/
+
+$(TARGET): $(objs) jhead
+ ${CC} $(LDFLAGS) $(LFLAGS) -o $(TARGET) $(objs)
+ ln -s ${TARGET} ${TARGET0}
+ ln -s ${TARGET} ${TARGET1}
+ ln -s ${TARGET} ${TARGET2}
+
+