summaryrefslogtreecommitdiff
path: root/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild')
-rw-r--r--media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
index a09a64ceb97d..d107dd8ad8ec 100644
--- a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
+++ b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit multilib versionator rpm
+inherit rpm
-MY_PV="$(get_version_component_range 1-3)"
-MY_PVR="$(replace_version_separator 3 -)"
+MY_PV="$(ver_cut 1-3)"
+MY_PVR="$(ver_rs 3 -)"
MY_P="esci-interpreter-gt-f720-${MY_PVR}"
DESCRIPTION="Epson Perfection V300 PHOTO scanner plugin for SANE 'epkowa' backend"
HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
SRC_URI="amd64? ( https://dev.gentoo.org/~flameeyes/avasys/${MY_P}.x86_64.rpm )
x86? ( https://dev.gentoo.org/~flameeyes/avasys/${MY_P}.i386.rpm )"
+S="${WORKDIR}"
LICENSE="AVASYS"
SLOT="0"
@@ -21,8 +22,6 @@ KEYWORDS="-* amd64 x86"
DEPEND=">=media-gfx/iscan-2.21.0"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
-
QA_PREBUILT="usr/lib64/esci/libesci-interpreter-gt-f720.so*"
src_install() {
@@ -42,15 +41,15 @@ pkg_postinst() {
local MY_LIB="/usr/$(get_libdir)"
# Needed for scaner to work properly.
- iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+ iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin" || die
elog
elog "Firmware file esfw8b.bin for Epson Perfection V300 PHOTO"
- elog "has been installed in /usr/share/esci and registered for use."
+ elog "has been installed in ${EROOT}/usr/share/esci and registered for use."
elog
}
pkg_prerm() {
local MY_LIB="/usr/$(get_libdir)"
- iscan-registry --remove interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+ iscan-registry --remove interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin" || die
}