summaryrefslogtreecommitdiff
path: root/media-gfx/ipe/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/ipe/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/ipe/files')
-rw-r--r--media-gfx/ipe/files/ipe-7.1.3-gold.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/ipe/files/ipe-7.1.3-gold.patch b/media-gfx/ipe/files/ipe-7.1.3-gold.patch
new file mode 100644
index 000000000000..a28fafa15c43
--- /dev/null
+++ b/media-gfx/ipe/files/ipe-7.1.3-gold.patch
@@ -0,0 +1,30 @@
+ src/ipe/Makefile | 2 +-
+ src/ipescript/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ipe/Makefile b/src/ipe/Makefile
+index 21ac500..5a7a1ad 100644
+--- a/src/ipe/Makefile
++++ b/src/ipe/Makefile
+@@ -10,7 +10,7 @@ TARGET = $(call exe_target,ipe)
+ CPPFLAGS += -I../include -I../ipecanvas -I../ipecairo -I../ipelua \
+ $(LUA_CFLAGS) $(UI_CFLAGS) $(CAIRO_CFLAGS) $(ZLIB_CFLAGS)
+ LIBS += -L$(buildlib) -lipecanvas -lipecairo -lipelua -lipe -lipeui \
+- $(LUA_LIBS) $(UI_LIBS) $(CAIRO_LIBS) $(ZLIB_LIBS)
++ $(LUA_LIBS) $(UI_LIBS) $(CAIRO_LIBS) $(ZLIB_LIBS) -ldl
+
+ CPPFLAGS += -DIPELETDIR=\"$(IPELETDIR)\"
+ CPPFLAGS += -DIPELUADIR=\"$(IPELUADIR)\"
+diff --git a/src/ipescript/Makefile b/src/ipescript/Makefile
+index ff35fd9..2315f1f 100644
+--- a/src/ipescript/Makefile
++++ b/src/ipescript/Makefile
+@@ -8,7 +8,7 @@ include ../common.mak
+ TARGET = $(call exe_target,ipescript)
+
+ CPPFLAGS += -I../include -I../ipelua $(LUA_CFLAGS)
+-LIBS += -L$(buildlib) -lipelua -lipe $(LUA_LIBS)
++LIBS += -L$(buildlib) -lipelua -lipe $(LUA_LIBS) -ldl
+
+ CPPFLAGS += -DIPELETDIR=\"$(IPELETDIR)\"
+ CPPFLAGS += -DIPESTYLEDIR=\"$(IPESTYLEDIR)\"