summaryrefslogtreecommitdiff
path: root/media-gfx/img2pdf/img2pdf-0.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 23:44:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 23:44:17 +0100
commitfdca6388cf31827202fae75cae067c695bd09339 (patch)
tree5021150295c139ea6a808950a9e1928b8ef593b8 /media-gfx/img2pdf/img2pdf-0.4.4.ebuild
parentb43fb9ec552fc1a84599161478d77c6716dd9e0a (diff)
gentoo auto-resync : 13:04:2023 - 23:44:17
Diffstat (limited to 'media-gfx/img2pdf/img2pdf-0.4.4.ebuild')
-rw-r--r--media-gfx/img2pdf/img2pdf-0.4.4.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-gfx/img2pdf/img2pdf-0.4.4.ebuild b/media-gfx/img2pdf/img2pdf-0.4.4.ebuild
deleted file mode 100644
index 1b42b2bc863c..000000000000
--- a/media-gfx/img2pdf/img2pdf-0.4.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Losslessly convert raster images to PDF"
-HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="gui"
-
-# pytest-xdist isn't really required but it helps speed up tests
-BDEPEND="
- test? (
- app-text/ghostscript-gpl
- app-text/mupdf
- app-text/poppler[cairo,png,tiff]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pdfrw[${PYTHON_USEDEP}]
- dev-python/pillow[tiff,${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- media-gfx/imagemagick[jpeg,jpeg2k,lcms,png,-q8,-q32,tiff]
- media-libs/exiftool
- media-libs/netpbm[jpeg]
- )
-"
-RDEPEND="
- dev-python/pikepdf[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- gui? ( $(python_gen_impl_dep tk) )
-"
-
-# gif animation test fails
-PATCHES=( "${FILESDIR}"/img2pdf-0.4.3-test-gif-animation.patch )
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_python_prepare_all
-
- # Remove gui executable if there's no demand/support for it.
- if ! use gui; then
- sed -i '/gui_scripts/d' setup.py || die
- fi
-
- # gif animation test fails
- rm src/tests/input/animation.gif src/tests/output/animation.gif.pdf || die "rm animation gif failes"
-}
-
-python_test() {
- epytest -n auto
-}