summaryrefslogtreecommitdiff
path: root/media-gfx/img2pdf/img2pdf-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /media-gfx/img2pdf/img2pdf-0.3.3.ebuild
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'media-gfx/img2pdf/img2pdf-0.3.3.ebuild')
-rw-r--r--media-gfx/img2pdf/img2pdf-0.3.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/img2pdf-0.3.3.ebuild b/media-gfx/img2pdf/img2pdf-0.3.3.ebuild
new file mode 100644
index 000000000000..9436b9466ccc
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pdfrw[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,zlib]
+ )"
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}