summaryrefslogtreecommitdiff
path: root/media-gfx/img2pdf/img2pdf-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /media-gfx/img2pdf/img2pdf-0.3.1.ebuild
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'media-gfx/img2pdf/img2pdf-0.3.1.ebuild')
-rw-r--r--media-gfx/img2pdf/img2pdf-0.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/img2pdf-0.3.1.ebuild b/media-gfx/img2pdf/img2pdf-0.3.1.ebuild
new file mode 100644
index 000000000000..9e0dd7864237
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pdfrw[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}