summaryrefslogtreecommitdiff
path: root/media-gfx/graphite2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
commitd479c9c5c724c7b1300a98e44975f31f4f2e51dd (patch)
treec2f5550bfe03e1b3f19014e1576dcf50e6bd818c /media-gfx/graphite2/files
parentee8ad1509f726e8fa598472117e5bbffd241ebab (diff)
gentoo auto-resync : 06:12:2022 - 21:11:24
Diffstat (limited to 'media-gfx/graphite2/files')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch45
-rw-r--r--media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch18
2 files changed, 0 insertions, 63 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch b/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
deleted file mode 100644
index a7e5804319d7..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-https://bugs.gentoo.org/829690
-
-See https://github.com/silnrsi/graphite/pull/44.
-
-Drop -nodefaultlibs:
-- graphite is written in C++ which makes avoiding libstdc++ (or libc++) a dubious
- goal;
-- this ends up breaking e.g. x86/musl because we need to inject -lssp_nonshared,
- but it wouldn't be surprising if it broke other exotic targets too.
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -105,7 +105,7 @@ set_target_properties(graphite2 PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
-@@ -135,7 +135,6 @@ endif()
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wimplicit-fallthrough -Wendif-labels -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -47,12 +47,12 @@ else (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
- set_target_properties(graphite2-base PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- set_target_properties(graphite2-file PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING${TELEMETRY}"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- endif()
-
diff --git a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
deleted file mode 100644
index b162ca9aa6f9..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://src.fedoraproject.org/rpms/graphite2/raw/41fb7c104c8f9293254abaa91bbda1daafb458cd/f/graphite-arm-nodefaultlibs.patch
-https://bugs.gentoo.org/829690
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -120,11 +120,7 @@
- if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
- target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
- else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
-- if (GRAPHITE2_SANITIZERS)
-- target_link_libraries(graphite2 c gcc_s)
-- else ()
-- target_link_libraries(graphite2 c gcc)
-- endif ()
-+ target_link_libraries(graphite2 c gcc_s)
- endif()
- include(Graphite)
- if (BUILD_SHARED_LIBS)
-