summaryrefslogtreecommitdiff
path: root/media-gfx/graphite2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /media-gfx/graphite2/files
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'media-gfx/graphite2/files')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-fix-cmake-files-libdir.patch13
-rw-r--r--media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch18
2 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-fix-cmake-files-libdir.patch b/media-gfx/graphite2/files/graphite2-1.3.14-fix-cmake-files-libdir.patch
new file mode 100644
index 000000000000..d4ae9846dce4
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.3.14-fix-cmake-files-libdir.patch
@@ -0,0 +1,13 @@
+Fix CMake install path. Noticed as part of the SSP patch (which we handle in
+the ebuild instead).
+
+https://git.alpinelinux.org/aports/tree/main/graphite2/cmake.patch?h=3.15-stable
+https://bugs.gentoo.org/829690
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -156,4 +152,4 @@ endif()
+
+
+ install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+-install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
++install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/cmake/graphite2 NAMESPACE gr2_)
diff --git a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
new file mode 100644
index 000000000000..b162ca9aa6f9
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
@@ -0,0 +1,18 @@
+https://src.fedoraproject.org/rpms/graphite2/raw/41fb7c104c8f9293254abaa91bbda1daafb458cd/f/graphite-arm-nodefaultlibs.patch
+https://bugs.gentoo.org/829690
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -120,11 +120,7 @@
+ if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
+ else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+- if (GRAPHITE2_SANITIZERS)
+- target_link_libraries(graphite2 c gcc_s)
+- else ()
+- target_link_libraries(graphite2 c gcc)
+- endif ()
++ target_link_libraries(graphite2 c gcc_s)
+ endif()
+ include(Graphite)
+ if (BUILD_SHARED_LIBS)
+