summaryrefslogtreecommitdiff
path: root/media-gfx/graphite2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-03 21:11:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-03 21:11:18 +0000
commit8ba493f5439ffec0ed21707f660602b7bd80bbbf (patch)
treea103c65926b64945179cd7435d608e9c761ebaf3 /media-gfx/graphite2/files
parentdc50ce612ba7a32ca77479875798989da2885437 (diff)
gentoo auto-resync : 03:02:2023 - 21:11:18
Diffstat (limited to 'media-gfx/graphite2/files')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch26
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.5-fix-gcc-linking.patch17
2 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch b/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
new file mode 100644
index 000000000000..c55f67c44f55
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
@@ -0,0 +1,26 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -125,7 +125,7 @@
+ LINK_FLAGS "-nostdlib++ ${GRAPHITE_LINK_FLAGS}")
+ else()
+ set_target_properties(graphite2 PROPERTIES
+- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}")
++ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}")
+
+ if (GRAPHITE2_SANITIZERS)
+ target_link_libraries(graphite2 c gcc_s)
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -51,9 +51,9 @@
+ LINK_FLAGS "-nostdlib++ ${GRAPHITE_LINK_FLAGS}")
+ else()
+ set_target_properties(graphite2-base PROPERTIES
+- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}")
++ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}")
+ set_target_properties(graphite2-file PROPERTIES
+- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}")
++ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}")
+ endif()
+
+ set_target_properties(graphite2-base PROPERTIES
+
diff --git a/media-gfx/graphite2/files/graphite2-1.3.5-fix-gcc-linking.patch b/media-gfx/graphite2/files/graphite2-1.3.5-fix-gcc-linking.patch
new file mode 100644
index 000000000000..e4413d1f9a61
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.3.5-fix-gcc-linking.patch
@@ -0,0 +1,17 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -127,12 +127,7 @@
+ set_target_properties(graphite2 PROPERTIES
+ LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}")
+
+- if (GRAPHITE2_SANITIZERS)
+- target_link_libraries(graphite2 c gcc_s)
+- else()
+- target_link_libraries(graphite2 c gcc)
+- endif()
+-
++ target_link_libraries(graphite2 c gcc_s)
+ if (BUILD_SHARED_LIBS)
+ nolib_test(stdc++ $<TARGET_SONAME_FILE:graphite2>)
+ endif ()
+