summaryrefslogtreecommitdiff
path: root/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /media-gfx/gozer/files/gozer-0.7-fix-build-system.patch
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'media-gfx/gozer/files/gozer-0.7-fix-build-system.patch')
-rw-r--r--media-gfx/gozer/files/gozer-0.7-fix-build-system.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch b/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch
new file mode 100644
index 000000000000..6102fe9c64c8
--- /dev/null
+++ b/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch
@@ -0,0 +1,51 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,14 +5,9 @@
+ # A list of all the files in the current directory which can be regenerated
+ MAINTAINERCLEANFILES = Makefile.in gozer.spec
+
+-LDFLAGS = -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib
+-INCLUDES = -I/usr/X11R6/include \
+-$(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I.
+-
+ man_MANS = gozer.1
+
+-docs_DATA = README AUTHORS ChangeLog TODO
+-docsdir = $(prefix)/doc/@PACKAGE@
++doc_DATA = README AUTHORS ChangeLog TODO
+
+ EXTRA_DIST = \
+ gozer.spec gozer.1 $(docs_DATA)
+--- a/src/fonts/Makefile.am
++++ b/src/fonts/Makefile.am
+@@ -8,6 +8,6 @@
+ fonts_DATA = \
+ helmetr.ttf
+
+-fontsdir=$(prefix)/share/@PACKAGE@/fonts
++fontsdir=$(prefix)/share/$(PACKAGE)/fonts
+
+ EXTRA_DIST = $(fonts_DATA)
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,15 +1,13 @@
+ # A list of all the files in the current directory which can be regenerated
+-MAINTAINERCLEANFILES = Makefile.in
++MAINTAINERCLEANFILES = Makefile.in
+
+ SUBDIRS = fonts
+
+-LDFLAGS = -L/usr/X11R6/lib
+-INCLUDES = -g -O3 -Wall -I/usr/X11R6/include \
+-$(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. \
+--DPREFIX=\""$(prefix)"\" @GIBLIB_CFLAGS@
+-LIBOBJS = @LIBOBJS@
++AM_CPPFLAGS = -Wall -I/usr/X11R6/include \
++ $(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. \
++ -DPREFIX=\""$(prefix)"\" $(GIBLIB_CFLAGS)
+
+ bin_PROGRAMS = gozer
+ gozer_SOURCES = main.c getopt.c getopt1.c getopt.h gozer.h \
+ options.c options.h debug.h utils.c utils.h imlib.c structs.h
+-gozer_LDADD = @GIBLIB_LIBS@
++gozer_LDADD = $(GIBLIB_LIBS) -L/usr/X11R6/lib