summaryrefslogtreecommitdiff
path: root/media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 03:02:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 03:02:28 +0000
commitb77e1a6cc7c668e135d139c5ec5ad0ae1c11b857 (patch)
tree41574d961a9788fa95e2a789a408e1c6fc151bd9 /media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild
parent009897642a869d630779716efc51af1554f72867 (diff)
gentoo auto-resync : 30:10:2022 - 03:02:28
Diffstat (limited to 'media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild')
-rw-r--r--media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild b/media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..45f4ea3f8cc7
--- /dev/null
+++ b/media-gfx/gnome-raw-thumbnailer/gnome-raw-thumbnailer-3.0.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2
+
+MY_P="${PN/gnome-}-${PV}"
+
+DESCRIPTION="A lightweight and fast raw image thumbnailer for GNOME"
+HOMEPAGE="https://libopenraw.pages.freedesktop.org/raw-thumbnailer/"
+SRC_URI="https://libopenraw.freedesktop.org/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/libopenraw-0.1.0:=[gtk]
+ >=x11-libs/gdk-pixbuf-2:2
+ >=dev-libs/glib-2.26:2
+ !media-gfx/raw-thumbnailer
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-deprecation-warning.patch
+ "${FILESDIR}"/${P}-fix-downscale.patch
+ "${FILESDIR}"/${P}-libopenraw-0.1.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}