summaryrefslogtreecommitdiff
path: root/media-gfx/gmic/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 03:29:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 03:29:03 +0000
commitb4899ed9fc78f45325ef4e2ebd460869e53a605d (patch)
tree22eb729a14c18edf4c1a015ec26189729e9c6272 /media-gfx/gmic/files
parentc020d9e9432cd0e36fe47ad14216d6048adb49fc (diff)
gentoo auto-resync : 11:11:2022 - 03:29:03
Diffstat (limited to 'media-gfx/gmic/files')
-rw-r--r--media-gfx/gmic/files/gmic-3.1.6-grep38.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/gmic/files/gmic-3.1.6-grep38.patch b/media-gfx/gmic/files/gmic-3.1.6-grep38.patch
new file mode 100644
index 000000000000..ec1df70002c3
--- /dev/null
+++ b/media-gfx/gmic/files/gmic-3.1.6-grep38.patch
@@ -0,0 +1,27 @@
+Starting with version 3.8, grep no longer quietly ignores backslashes
+preceding a white-space character.
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -88,16 +88,16 @@
+ EXE =
+ WGET = wget --no-check-certificate --quiet -O
+ PLUGINDIR = $(shell gimptool-2.0 --gimpplugindir)/plug-ins
+-VERSION = $(shell grep 'gmic_version\ ' gmic.h | tail -c4 | head -c3)
+-VERSION1 = $(shell grep 'gmic_version\ ' gmic.h | tail -c4 | head -c1)
+-VERSION2 = $(shell grep 'gmic_version\ ' gmic.h | tail -c3 | head -c1)
+-VERSION3 = $(shell grep 'gmic_version\ ' gmic.h | tail -c2 | head -c1)
++VERSION = $(shell grep 'gmic_version ' gmic.h | tail -c4 | head -c3)
++VERSION1 = $(shell grep 'gmic_version ' gmic.h | tail -c4 | head -c1)
++VERSION2 = $(shell grep 'gmic_version ' gmic.h | tail -c3 | head -c1)
++VERSION3 = $(shell grep 'gmic_version ' gmic.h | tail -c2 | head -c1)
+ SVERSION=$(VERSION1).$(VERSION2).$(VERSION3)
+ SRC_PATH=$(shell pwd)
+
+ # Check that versions of files 'CImg.h' and 'gmic.h' match.
+ ifneq (,$(wildcard CImg.h))
+-CIMG_VERSION = $(shell grep 'cimg_version\ ' CImg.h | tail -c4 | head -c3)
++CIMG_VERSION = $(shell grep 'cimg_version ' CImg.h | tail -c4 | head -c3)
+ else
+ CIMG_VERSION = $(VERSION)
+ endif