summaryrefslogtreecommitdiff
path: root/media-gfx/gmic/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/gmic/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/gmic/files')
-rw-r--r--media-gfx/gmic/files/gmic-2.9.2_ipa-sra.patch15
-rw-r--r--media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch28
2 files changed, 28 insertions, 15 deletions
diff --git a/media-gfx/gmic/files/gmic-2.9.2_ipa-sra.patch b/media-gfx/gmic/files/gmic-2.9.2_ipa-sra.patch
deleted file mode 100644
index 384856a0464f..000000000000
--- a/media-gfx/gmic/files/gmic-2.9.2_ipa-sra.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-A GCC-specific setting from years ago. gcc-9 quietly ignores it (the
-resulting binaries appear to be the same whether -fno-ipa-sra has been
-specified or not), clang fails on it as not recognised.
-Just get rid of it altogether.
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -100,7 +100,7 @@
- if(APPLE)
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -mmacosx-version-min=10.8 -stdlib=libc++ -Wno-error=c++11-narrowing -Wc++11-extensions -fpermissive")
- else()
-- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-error=narrowing -fno-ipa-sra -fpermissive")
-+ set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-error=narrowing -fpermissive")
- endif()
-
- if(NOT "${PRERELEASE_TAG}" STREQUAL "")
diff --git a/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch b/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch
new file mode 100644
index 000000000000..e97ef6bf6138
--- /dev/null
+++ b/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch
@@ -0,0 +1,28 @@
+https://src.fedoraproject.org/rpms/gmic/raw/rawhide/f/gmic-openexr3.patch
+--- a/cmake/FindCImg.cmake
++++ b/cmake/FindCImg.cmake
+@@ -147,7 +147,10 @@ if(ENABLE_JPEG)
+ endif()
+
+ if(ENABLE_OPENEXR)
+- find_package(OpenEXR)
++ find_package(OpenEXR CONFIG)
++ if(NOT TARGET OpenEXR::OpenEXR)
++ find_package(OpenEXR)
++ endif()
+
+ if(OpenEXR_FOUND)
+ list(APPEND CLI_COMPILE_FLAGS "cimg_use_openexr")
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -307,8 +307,8 @@
+
+ # Enable native support of EXR image files, using the OpenEXR library.
+ # (http://www.openexr.com/)
+-OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR)
+-OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lIlmImf -lHalf)
++OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR -I$(USR)/$(INCLUDE)/Imath)
++OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lOpenEXR -lImath)
+
+ # Enable Fast Fourier Transforms, using the FFTW3 library.
+ # (http://www.fftw.org/)