summaryrefslogtreecommitdiff
path: root/media-gfx/gimp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 04:17:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 04:17:09 +0100
commit388a0747e5972613060d5ca13955b5cd7132533d (patch)
tree428632822fc3fccc6f83e13091c09d6c19ad51bc /media-gfx/gimp/files
parent89da5c5ac79849bb6d8b087cb9c1e554187bd59c (diff)
gentoo auto-resync : 20:05:2023 - 04:17:09
Diffstat (limited to 'media-gfx/gimp/files')
-rw-r--r--media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch24
-rw-r--r--media-gfx/gimp/files/gimp-2.10_fix_musl_backtrace_backend_switch.patch15
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch b/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
new file mode 100644
index 000000000000..a266fb94a996
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
@@ -0,0 +1,24 @@
+Gentoo issue: https://bugs.gentoo.org/899796
+
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1291,13 +1291,14 @@
+ #include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+- int main()
++ #include <stdlib.h>
++ int main(void)
+ {
+ int id;
+ char *shmaddr;
+- id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0600);
+- if (id == -1)
+- exit (2);
++ id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0600);
++ if (id == -1)
++ exit (2);
+ shmaddr = shmat (id, 0, 0);
+ shmctl (id, IPC_RMID, 0);
+ if ((char*) shmat (id, 0, 0) == (char*) -1)
diff --git a/media-gfx/gimp/files/gimp-2.10_fix_musl_backtrace_backend_switch.patch b/media-gfx/gimp/files/gimp-2.10_fix_musl_backtrace_backend_switch.patch
new file mode 100644
index 000000000000..07f0266d0a30
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.10_fix_musl_backtrace_backend_switch.patch
@@ -0,0 +1,15 @@
+Gentoo issue: https://bugs.gentoo.org/900148
+Upstream issue: https://gitlab.gnome.org/GNOME/gimp/-/issues/9452
+
+diff -Naur a/app/core/gimpbacktrace-backend.h b/app/core/gimpbacktrace-backend.h
+--- a/app/core/gimpbacktrace-backend.h
++++ b/app/core/gimpbacktrace-backend.h
+@@ -22,7 +22,7 @@
+ #define __GIMP_BACKTRACE_BACKEND_H__
+
+
+-#ifdef __gnu_linux__
++#if defined (__gnu_linux__) && defined (__GLIBC__)
+ # define GIMP_BACKTRACE_BACKEND_LINUX
+ #elif defined (G_OS_WIN32) && defined (ARCH_X86)
+ # define GIMP_BACKTRACE_BACKEND_WINDOWS