summaryrefslogtreecommitdiff
path: root/media-gfx/gifsicle/gifsicle-1.91.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /media-gfx/gifsicle/gifsicle-1.91.ebuild
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'media-gfx/gifsicle/gifsicle-1.91.ebuild')
-rw-r--r--media-gfx/gifsicle/gifsicle-1.91.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/gifsicle/gifsicle-1.91.ebuild b/media-gfx/gifsicle/gifsicle-1.91.ebuild
new file mode 100644
index 000000000000..178513885a6f
--- /dev/null
+++ b/media-gfx/gifsicle/gifsicle-1.91.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Create, manipulate, and optimize GIF images and animations"
+HOMEPAGE="https://www.lcdf.org/~eddietwo/gifsicle/ https://github.com/kohler/gifsicle"
+SRC_URI="https://www.lcdf.org/~eddietwo/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="X"
+
+RDEPEND="
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+DOCS=(
+ NEWS.md
+ README.md
+)
+
+src_configure() {
+ econf $(usex X "" "--disable-gifview")
+}