summaryrefslogtreecommitdiff
path: root/media-gfx/gifsicle/gifsicle-1.90.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/gifsicle/gifsicle-1.90.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/gifsicle/gifsicle-1.90.ebuild')
-rw-r--r--media-gfx/gifsicle/gifsicle-1.90.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/gifsicle/gifsicle-1.90.ebuild b/media-gfx/gifsicle/gifsicle-1.90.ebuild
new file mode 100644
index 000000000000..1787353501e5
--- /dev/null
+++ b/media-gfx/gifsicle/gifsicle-1.90.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Create, manipulate, and optimize GIF images and animations"
+HOMEPAGE="https://www.lcdf.org/~eddietwo/gifsicle/ https://github.com/kohler/gifsicle"
+SRC_URI="https://www.lcdf.org/~eddietwo/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11 x11-libs/libXt )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_configure() {
+ econf $(usex X "" "--disable-gifview")
+}