summaryrefslogtreecommitdiff
path: root/media-gfx/gif2png/gif2png-2.5.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /media-gfx/gif2png/gif2png-2.5.12.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'media-gfx/gif2png/gif2png-2.5.12.ebuild')
-rw-r--r--media-gfx/gif2png/gif2png-2.5.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/gif2png/gif2png-2.5.12.ebuild b/media-gfx/gif2png/gif2png-2.5.12.ebuild
new file mode 100644
index 000000000000..937a694a8ebb
--- /dev/null
+++ b/media-gfx/gif2png/gif2png-2.5.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Converts images from gif format to png format"
+HOMEPAGE="http://catb.org/~esr/gif2png/"
+SRC_URI="http://catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND=">=media-libs/libpng-1.2:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.12-makefile.patch
+)
+
+src_prepare() {
+ default
+
+ # this release lacks the NEWS file that is being used to
+ # query the release version
+ # https://gitlab.com/esr/gif2png/issues/4
+ sed "s@^VERSION.*@VERSION = ${PV}@" -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}