summaryrefslogtreecommitdiff
path: root/media-gfx/freecad/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /media-gfx/freecad/files
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'media-gfx/freecad/files')
-rw-r--r--media-gfx/freecad/files/freecad-0.17_pre-no-webkit.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/freecad/files/freecad-0.17_pre-no-webkit.patch b/media-gfx/freecad/files/freecad-0.17_pre-no-webkit.patch
new file mode 100644
index 000000000000..60dcfed22c7d
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.17_pre-no-webkit.patch
@@ -0,0 +1,45 @@
+Description: Remove Qt4-Webkit dependency
+Author: Anton Gladky <gladk@debian.org>
+Bug-Debian: https://bugs.debian.org/784464
+Last-Update: 2017-09-06
+
+* asturm: tidied up and amended to use and not override BUILD_WEB
+
+--- a/src/Gui/DownloadManager.cpp
++++ b/src/Gui/DownloadManager.cpp
+@@ -33,7 +33,6 @@
+ #include <QMetaEnum>
+ #include <QSettings>
+ #include <QFileIconProvider>
+-#include <QWebSettings>
+
+ #include "DownloadItem.h"
+ #include "DownloadManager.h"
+@@ -224,11 +223,12 @@ void DownloadManager::updateRow()
+ ui->downloadsView->setRowHeight(row, item->minimumSizeHint().height());
+
+ bool remove = false;
++/*
+ QWebSettings *globalSettings = QWebSettings::globalSettings();
+ if (!item->downloading()
+ && globalSettings->testAttribute(QWebSettings::PrivateBrowsingEnabled))
+ remove = true;
+-
++*/
+ if (item->downloadedSuccessfully()
+ && removePolicy() == DownloadManager::SuccessFullDownload) {
+ remove = true;
+--- a/CMakeLists.txt 2018-03-02 22:39:46.374140506 +0100
++++ b/CMakeLists.txt 2018-03-02 22:41:59.904216932 +0100
+@@ -351,11 +351,6 @@
+ set(BUILD_MESH ON)
+ endif(BUILD_JTREADER)
+
+-#a runtime dependency
+-if(BUILD_START)
+- set(BUILD_WEB ON)
+-endif(BUILD_START)
+-
+ #leaving test module for someone else.
+ #image has none. as far as I can tell.
+ #mesh has none. as far as I can tell.