summaryrefslogtreecommitdiff
path: root/media-gfx/freecad/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/freecad/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/freecad/files')
-rw-r--r--media-gfx/freecad/files/freecad-0.14.3702-install-paths.patch21
-rw-r--r--media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch16
-rw-r--r--media-gfx/freecad/files/freecad.sharedmimeinfo8
3 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/freecad/files/freecad-0.14.3702-install-paths.patch b/media-gfx/freecad/files/freecad-0.14.3702-install-paths.patch
new file mode 100644
index 000000000000..d042695e88c6
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.14.3702-install-paths.patch
@@ -0,0 +1,21 @@
+--- freecad-0.14.3702/CMakeLists.txt
++++ freecad-0.14.3702/CMakeLists.txt
+@@ -69,9 +69,15 @@
+ SET(CMAKE_INSTALL_PREFIX "/usr/lib${LIB_SUFFIX}/freecad" CACHE PATH "Installation root directory")
+ endif(WIN32)
+
+-SET(CMAKE_INSTALL_DATADIR data CACHE PATH "Output directory for data and resource files")
+-SET(CMAKE_INSTALL_INCLUDEDIR include CACHE PATH "Output directory for header files")
+-SET(CMAKE_INSTALL_DOCDIR doc CACHE PATH "Output directory for documentation and license files")
++if(NOT CMAKE_INSTALL_DATADIR)
++ SET(CMAKE_INSTALL_DATADIR data CACHE PATH "Output directory for data and resource files")
++endif(NOT CMAKE_INSTALL_DATADIR)
++if(NOT CMAKE_INSTALL_INCLUDEDIR)
++ SET(CMAKE_INSTALL_INCLUDEDIR include CACHE PATH "Output directory for header files")
++endif(NOT CMAKE_INSTALL_INCLUDEDIR)
++if(NOT CMAKE_INSTALL_DOCDIR)
++ SET(CMAKE_INSTALL_DOCDIR doc CACHE PATH "Output directory for documentation and license files")
++endif(NOT CMAKE_INSTALL_DOCDIR)
+ # Don't set it without manual adaption of LibDir variable in src/App/FreeCADInit.py
+ SET(CMAKE_INSTALL_LIBDIR lib CACHE PATH "Output directory for libraries")
+
diff --git a/media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch b/media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch
new file mode 100644
index 000000000000..4a7dbabdfc55
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch
@@ -0,0 +1,16 @@
+From e0683f4db0fb56f8139f78ca2e500b21ec2a67f0 Mon Sep 17 00:00:00 2001
+From: wmayer <wmayer@users.sourceforge.net>
+Date: Mon, 28 Dec 2015 13:54:40 +0100
+Subject: [PATCH] + fixes #0002347: freecad fails to build with Boost 1.60.0
+
+--- freecad-0.15.4671/src/Mod/Drawing/App/FeaturePage.cpp
++++ freecad-0.15.4671/src/Mod/Drawing/App/FeaturePage.cpp
+@@ -195,7 +195,7 @@
+ if (count < editText.size()) {
+ // change values of editable texts
+ boost::regex e2 ("(<text.*?freecad:editable=\""+what[1].str()+"\".*?<tspan.*?)>(.*?)(</tspan>)");
+- boost::re_detail::string_out_iterator<std::string > out(newfragment);
++ std::back_insert_iterator<std::string> out(newfragment);
+ boost::regex_replace(out, begin, what[0].second, e2, "$1>"+editText[count]+"$3");
+ }
+ count++;
diff --git a/media-gfx/freecad/files/freecad.sharedmimeinfo b/media-gfx/freecad/files/freecad.sharedmimeinfo
new file mode 100644
index 000000000000..6d5e93e7d13c
--- /dev/null
+++ b/media-gfx/freecad/files/freecad.sharedmimeinfo
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-extension-fcstd">
+ <!-- <sub-class-of type="application/zip"/> -->
+ <comment>FreeCAD document files</comment>
+ <glob pattern="*.fcstd"/>
+ </mime-type>
+</mime-info>