summaryrefslogtreecommitdiff
path: root/media-gfx/fotoxx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /media-gfx/fotoxx/files
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'media-gfx/fotoxx/files')
-rw-r--r--media-gfx/fotoxx/files/fotoxx-15.05-docdir.patch (renamed from media-gfx/fotoxx/files/fotoxx-15.05.patch)1
-rw-r--r--media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch31
2 files changed, 31 insertions, 1 deletions
diff --git a/media-gfx/fotoxx/files/fotoxx-15.05.patch b/media-gfx/fotoxx/files/fotoxx-15.05-docdir.patch
index 15fdaa9abacf..8cab49ff51ea 100644
--- a/media-gfx/fotoxx/files/fotoxx-15.05.patch
+++ b/media-gfx/fotoxx/files/fotoxx-15.05-docdir.patch
@@ -1,4 +1,3 @@
-diff -r -U1 fotoxx-14.10.2.orig/Makefile fotoxx-14.10.2/Makefile
--- fotoxx-14.10.2.orig/Makefile 2014-10-09 15:17:09.000000000 +0700
+++ fotoxx-14.10.2/Makefile 2014-10-13 20:44:55.061728475 +0700
@@ -16,3 +16,3 @@
diff --git a/media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch b/media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch
new file mode 100644
index 000000000000..5d84e687d397
--- /dev/null
+++ b/media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch
@@ -0,0 +1,31 @@
+Fix 'smart_erase_blur' declaration and definition mismatch.
+
+https://bugs.gentoo.org/768207
+--- a/f.repair.cc
++++ b/f.repair.cc
+@@ -2265,7 +2265,7 @@ void smart_erase_func(int mode)
+
+ // add blur to the erased area to help mask the side-effects
+
+-int smart_erase_blur(float radius)
++void smart_erase_blur(float radius)
+ {
+ int ii, px, py, dx, dy, adx, ady;
+ float blur_weight[12][12]; // up to blur radius = 10
+@@ -2274,7 +2274,7 @@ int smart_erase_blur(float radius)
+ float red, green, blue;
+ float *pix9, *pix3, *pixN;
+
+- if (sa_stat != 3) return 0;
++ if (sa_stat != 3) return;
+
+ rad = radius - 0.2;
+ rad2 = rad * rad;
+@@ -2342,7 +2342,6 @@ int smart_erase_blur(float radius)
+ CEF->Fmods++;
+ CEF->Fsaved = 0;
+ Fpaint2(); // update window
+- return 0;
+ }
+
+