summaryrefslogtreecommitdiff
path: root/media-gfx/fotoxx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-gfx/fotoxx/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-gfx/fotoxx/files')
-rw-r--r--media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch b/media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch
new file mode 100644
index 000000000000..523c640cc001
--- /dev/null
+++ b/media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch
@@ -0,0 +1,33 @@
+diff -ur a/Makefile b/Makefile
+--- a/Makefile 2021-04-08 10:05:46.064519573 -0500
++++ b/Makefile 2021-04-08 10:51:26.906128397 -0500
+@@ -97,6 +97,7 @@
+
+ zfuncs.o: zfuncs.cc zfuncs.h
+ $(CXX) zfuncs.cc $(CFLAGS) \
++ -D DOCDIR=\"$(DOCDIR)\" \
+
+ # install application files in standard locations
+ PREFIX ?= /usr
+@@ -122,8 +123,7 @@
+ cp -f -R data/* $(DESTDIR)$(DATADIR)
+ cp -f -R images/* $(DESTDIR)$(IMAGEDIR)
+ # man page (21.29)
+- gzip -fk -9 man/fotoxx.man
+- mv -f man/fotoxx.man.gz $(DESTDIR)$(MANDIR)/fotoxx.1.gz
++ cp man/fotoxx.man $(DESTDIR)$(MANDIR)/fotoxx.1
+ # desktop file and icon
+ cp -f fotoxx.desktop $(DESTDIR)$(MENUDIR)
+ cp -f fotoxx.png $(DESTDIR)$(ICONDIR)
+diff -ur a/zfuncs.cc b/zfuncs.cc
+--- a/zfuncs.cc 2021-04-08 10:05:46.062519630 -0500
++++ b/zfuncs.cc 2021-04-08 11:09:07.977258807 -0500
+@@ -5615,7 +5615,7 @@
+
+ strncatv(zdatadir,199,zprefix,"/share/",zappname,"/data",null); // /prefix/share/appname/data
+ strncatv(zimagedir,199,zprefix,"/share/",zappname,"/images",null); // /prefix/share/appname/images
+- strncatv(zdocdir,199,zprefix,"/share/doc/",zappname,null); // /prefix/share/doc/appname
++ strncatv(zdocdir,199,zprefix,"/share/doc/",zappvers,null); // /prefix/share/doc/appname
+
+ ch_time = zstrdup(build_date_time,"zinitapp");
+ if (ch_time[4] == ' ') ch_time[4] = '0'; // replace month day ' d' with '0d'