summaryrefslogtreecommitdiff
path: root/media-gfx/exiv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /media-gfx/exiv2
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/Manifest2
-rw-r--r--media-gfx/exiv2/exiv2-0.28.0.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index b1ba76864207..98f5cf8d151b 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1,4 +1,6 @@
AUX exiv2-0.27.6-jxl-mime.patch 2704 BLAKE2B b7d88658863aef95717b917c006b609279b09f808fb415c9c42b648b61403c0b9fa2c4552470d943ea2b03212fa06fb6c6607cf7331ae0a47ad11a1a1b811e08 SHA512 6461be2af1a4e4318da2b2fdd623e0396de4f43a62b20fb58e7ceac1aa3394bf848ab0107c99267324a7a613cc1a46b68e44696dd3af9eb4bb2c9b0d7b3fe988
DIST exiv2-0.27.6-Source.tar.gz 32280263 BLAKE2B a025452b7e70aef109a2f7831ba5c0528b0cb8fda92e5959a5927abd442d650f8d40cc47f56d8f87508e5f37e8378728f99e3a4fa96e7a0319cb4542659d9a60 SHA512 045d7fb391202b53897336094812600680141a292367a9194e9529bccb8ab54465190ea0f0636970114402a38840b33b2fcf2edf7b6c616f3e585fa295a887a4
+DIST exiv2-0.28.0.tar.gz 45138274 BLAKE2B 6ccdc4e6a7dbd4aa2a892e61306f0c63659d804075cae9e771096cfdc21ec0aff0df22232c036551f4e321f497184e7ad100fb9c2011c14cd0315e8118c3e85f SHA512 35e483c6123f099167ed8647fae7c6e5512434c24d0afe684180ba6a5114068d5678280a01c8e6cfee0d1e555e1dc2a1606989d46950ce3ef1a3859caeed4dad
EBUILD exiv2-0.27.6.ebuild 2865 BLAKE2B bda1b89e1ce81e20bd58705a46e84be82bd2e28d646c77a46cd5655f4819086de521587c93d3fde2eebd51cb0a96c50c56c89407b2241e9b16eaf54e99cee9ae SHA512 6f2e6144c34ba0c272334cdbfddc9dbefbb157cf030072f0e274e6f2586c7190189cfa341f35bf2ad493085a80aa2a2d013518ce87bdbb24b9ad104f53b7b77a
+EBUILD exiv2-0.28.0.ebuild 3189 BLAKE2B 7f38184e6d2d8fbd1ed76fa9f38b9670512d2c9675d9c6c24da5c83621e70939377e5903222b299d0eb6998c75927c8fe08d66945c3f5bb7798a7c3d5e7184ec SHA512 64c6ba378dc2949cf4cf97677f12e5b1404c040f79f622b25ab1842399a1fad93b6ebb8981ea93b2424ae7d90669d9f1977ba1201de1cc82fea78e01643340ca
MISC metadata.xml 686 BLAKE2B 2d1079660cf4268216f8835d1ae6655ebafc99d5402872bb05dac6342034a28a07dcff587fc616a5eedc8c538ea3e43e013711d39c2541295e89629e39a244ee SHA512 40f9225a42386fa6f03bf9436d675bb01bd6eb859974bfed22d1316536ceaf40752fabffdab20b439e87c57f65d193d8d249e5aa022584de3f869f4162660b4e
diff --git a/media-gfx/exiv2/exiv2-0.28.0.ebuild b/media-gfx/exiv2/exiv2-0.28.0.ebuild
new file mode 100644
index 000000000000..fa09f5d3504a
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.28.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://exiv2.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Exiv2/exiv2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+# Upstream hope to have stable ABI in 1.0. Until then, go off ${PV}.
+# We may be able to change it to $(ver_cut 1-2) once e.g.
+# https://github.com/Exiv2/exiv2/pull/917 is merged.
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+bmff doc examples nls +png test webready +xmp"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? (
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${DEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ test? ( ${PYTHON_DEPS} )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+pkg_setup() {
+ if use doc || use test ; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ cmake_src_prepare
+
+ sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BROTLI=OFF
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_INIH=OFF # multilib/libdir logic is broken
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_BMFF=$(usex bmff)
+
+ # We let users control this.
+ -DBUILD_WITH_CCACHE=OFF
+ # Our toolchain sets this by default.
+ -DBUILD_WITH_STACK_PROTECTOR=OFF
+
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_UNIT_TESTS=$(usex test))
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ if use doc || use test ; then
+ mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && eninja doc
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ cd "${BUILD_DIR}"/bin || die
+ ./unit_tests || die "Failed to run tests"
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}