summaryrefslogtreecommitdiff
path: root/media-gfx/entice/entice-0_pre20220809.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
commitc7c8d625ecbe5f95c445995303ed9b0e1f0de507 (patch)
treef0e6e5b3d8a377cf309b6085c2c7a30e640f84a1 /media-gfx/entice/entice-0_pre20220809.ebuild
parentd6fe3a53bdeea6b060d1755199cc2c27492dc14c (diff)
gentoo auto-resync : 10:04:2023 - 17:37:14
Diffstat (limited to 'media-gfx/entice/entice-0_pre20220809.ebuild')
-rw-r--r--media-gfx/entice/entice-0_pre20220809.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/entice/entice-0_pre20220809.ebuild b/media-gfx/entice/entice-0_pre20220809.ebuild
new file mode 100644
index 000000000000..4911690177c2
--- /dev/null
+++ b/media-gfx/entice/entice-0_pre20220809.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature xdg
+
+MY_COMMIT="5122896d812a2db0fd2c536f047ac340fd1d12e5"
+
+DESCRIPTION="A simple image viewer based on EFL"
+HOMEPAGE="https://git.enlightenment.org/vtorri/entice https://github.com/vtorri/entice"
+SRC_URI="https://github.com/vtorri/entice/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ media-libs/libexif"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/entice-${MY_COMMIT}"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature_header "Image format support:"
+ optfeature "avif support" dev-libs/efl[avif]
+ optfeature "bmp,wbmp support" dev-libs/efl[bmp]
+ optfeature "dds support" dev-libs/efl[dds]
+ optfeature "gif support" dev-libs/efl[gif]
+ optfeature "heif support" dev-libs/efl[heif]
+ optfeature "ico,cur support" dev-libs/efl[ico]
+ optfeature "jp2k support" dev-libs/efl[jpeg2k]
+ optfeature "pdf support" dev-libs/efl[pdf]
+ optfeature "pmaps support" dev-libs/efl[pmaps]
+ optfeature "psd support" dev-libs/efl[psd]
+ optfeature "raw support" dev-libs/efl[raw]
+ optfeature "svg,rsvg support" dev-libs/efl[svg]
+ optfeature "tga support" dev-libs/efl[tga]
+ optfeature "tgv support" dev-libs/efl[tgv]
+ optfeature "tiff support" dev-libs/efl[tiff]
+ optfeature "webp support" dev-libs/efl[webp]
+ optfeature "xcf support" dev-libs/efl[xcf]
+ optfeature "xpm support" dev-libs/efl[xpm]
+}