summaryrefslogtreecommitdiff
path: root/media-gfx/entice/entice-0_pre20210919-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /media-gfx/entice/entice-0_pre20210919-r1.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'media-gfx/entice/entice-0_pre20210919-r1.ebuild')
-rw-r--r--media-gfx/entice/entice-0_pre20210919-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/entice/entice-0_pre20210919-r1.ebuild b/media-gfx/entice/entice-0_pre20210919-r1.ebuild
new file mode 100644
index 000000000000..a11d1c9be8e4
--- /dev/null
+++ b/media-gfx/entice/entice-0_pre20210919-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature xdg
+
+MY_COMMIT="8b62c4ff8eeadd37d5304a01b287da3011283b66"
+
+DESCRIPTION="A simple image viewer based on EFL"
+HOMEPAGE="https://github.com/vtorri/entice"
+SRC_URI="https://github.com/vtorri/entice/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ media-libs/libexif"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/entice-${MY_COMMIT}"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature_header "Image format support:"
+ optfeature "avif support" dev-libs/efl[avif]
+ optfeature "bmp,wbmp support" dev-libs/efl[bmp]
+ optfeature "dds support" dev-libs/efl[dds]
+ optfeature "gif support" dev-libs/efl[gif]
+ optfeature "heif support" dev-libs/efl[heif]
+ optfeature "ico,cur support" dev-libs/efl[ico]
+ optfeature "jp2k support" dev-libs/efl[jpeg2k]
+ optfeature "pmaps support" dev-libs/efl[pmaps]
+ optfeature "psd support" dev-libs/efl[psd]
+ optfeature "raw support" dev-libs/efl[raw]
+ optfeature "svg,rsvg support" dev-libs/efl[svg]
+ optfeature "tga support" dev-libs/efl[tga]
+ optfeature "tgv support" dev-libs/efl[tgv]
+ optfeature "tiff support" dev-libs/efl[tiff]
+ optfeature "webp support" dev-libs/efl[webp]
+ optfeature "xcf support" dev-libs/efl[xcf]
+ optfeature "xpm support" dev-libs/efl[xpm]
+}