summaryrefslogtreecommitdiff
path: root/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild')
-rw-r--r--media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild b/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
new file mode 100644
index 000000000000..64e4f8d7f285
--- /dev/null
+++ b/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ASCII art editor"
+HOMEPAGE="http://www.cs.helsinki.fi/u/penberg/duhdraw"
+SRC_URI="http://www.cs.helsinki.fi/u/penberg/duhdraw/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-macos.patch
+ epatch "${FILESDIR}"/${P}-prestrip.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin ansi ansitoc duhdraw
+ dodoc CREDITS HISTORY TODO
+}