summaryrefslogtreecommitdiff
path: root/media-gfx/dpic/dpic-20130310.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/dpic/dpic-20130310.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/dpic/dpic-20130310.ebuild')
-rw-r--r--media-gfx/dpic/dpic-20130310.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/dpic/dpic-20130310.ebuild b/media-gfx/dpic/dpic-20130310.ebuild
new file mode 100644
index 000000000000..a21a1659b42e
--- /dev/null
+++ b/media-gfx/dpic/dpic-20130310.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Converts PIC plots into pstricks, PGF/TikZ, PostScript, MetaPost and TeX"
+HOMEPAGE="http://ece.uwaterloo.ca/~aplevich/dpic"
+SRC_URI="https://ece.uwaterloo.ca/~aplevich/dpic/${PN}-2013.03.10.tar.gz"
+
+LICENSE="BSD-2 CC-BY-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile () {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin dpic
+ doman doc/dpic.1
+ dodoc README CHANGES doc/dpicdoc.pdf doc/gpic.pdf
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}