summaryrefslogtreecommitdiff
path: root/media-gfx/digikam/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
commite3cf2c86fca1750343c1885311f857f185ee4f2d (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /media-gfx/digikam/files
parentf1af93971b7490792d8541bc790e0d8c6d787059 (diff)
gentoo resync : 08.09.2019
Diffstat (limited to 'media-gfx/digikam/files')
-rw-r--r--media-gfx/digikam/files/digikam-6.3.0-cmake.patch66
-rw-r--r--media-gfx/digikam/files/digikam-6.3.0-googlephoto-import-crash.patch85
2 files changed, 151 insertions, 0 deletions
diff --git a/media-gfx/digikam/files/digikam-6.3.0-cmake.patch b/media-gfx/digikam/files/digikam-6.3.0-cmake.patch
new file mode 100644
index 000000000000..f14f406d88d5
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-6.3.0-cmake.patch
@@ -0,0 +1,66 @@
+From beb8eb984aac519ed5dfd13615f430ec14e73f16 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 17 Feb 2019 23:51:03 +0100
+Subject: [PATCH] Un-break optional Qt5 detection
+
+---
+ core/CMakeLists.txt | 26 ++++++++++----------------
+ 1 file changed, 10 insertions(+), 16 deletions(-)
+
+diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
+index 633760d194..736826d234 100644
+--- a/core/CMakeLists.txt
++++ b/core/CMakeLists.txt
+@@ -136,16 +136,14 @@ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED
+ )
+
+ if(ENABLE_QWEBENGINE)
+- find_package(Qt5 ${QT_MIN_VERSION} NO_MODULE COMPONENTS WebEngineWidgets)
++ find_package(Qt5WebEngineWidgets ${QT_MIN_VERSION} NO_MODULE)
+ else()
+- find_package(Qt5 ${QT_MIN_VERSION} NO_MODULE COMPONENTS WebKitWidgets)
++ find_package(Qt5WebKitWidgets ${QT_MIN_VERSION} NO_MODULE)
+ endif()
+
+-find_package(Qt5 ${QT_MIN_VERSION}
+- OPTIONAL_COMPONENTS
+- DBus
+- OpenGL
+-)
++find_package(Qt5DBus ${QT_MIN_VERSION})
++
++find_package(Qt5OpenGL ${QT_MIN_VERSION})
+
+ if(ENABLE_DBUS)
+ if(NOT Qt5DBus_FOUND)
+@@ -156,14 +154,10 @@ endif()
+ # Dependencies For unit tests and CLI test tools
+
+ if(BUILD_TESTING)
+- find_package(Qt5 ${QT_MIN_VERSION} REQUIRED
+- NO_MODULE COMPONENTS
+- Test
+- )
+- find_package(Qt5 ${QT_MIN_VERSION}
+- OPTIONAL_COMPONENTS
+- Qml WebView # Optional, for 'sialis' O2 library test tool.
+- )
++ find_package(Qt5Test ${QT_MIN_VERSION} NO_MODULE)
++ # Optional, for 'sialis' O2 library test tool.
++ find_package(Qt5Qml ${QT_MIN_VERSION} NO_MODULE)
++ find_package(Qt5WebView ${QT_MIN_VERSION} NO_MODULE)
+ endif()
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+@@ -335,7 +329,7 @@ endif()
+ find_package(X11)
+
+ if(X11_FOUND)
+- find_package(Qt5 ${QT_MIN_VERSION} NO_MODULE COMPONENTS X11Extras)
++ find_package(Qt5X11Extras ${QT_MIN_VERSION} NO_MODULE)
+ set(HAVE_X11 TRUE)
+ else()
+ set(HAVE_X11 FALSE)
+--
+2.23.0
+
diff --git a/media-gfx/digikam/files/digikam-6.3.0-googlephoto-import-crash.patch b/media-gfx/digikam/files/digikam-6.3.0-googlephoto-import-crash.patch
new file mode 100644
index 000000000000..7a8a7e533a13
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-6.3.0-googlephoto-import-crash.patch
@@ -0,0 +1,85 @@
+From ea22af510d62c85224ed430611db8818f97ecc69 Mon Sep 17 00:00:00 2001
+From: Maik Qualmann <metzpinguin@gmail.com>
+Date: Wed, 4 Sep 2019 20:59:20 +0200
+Subject: fix crash when close/reopen Google import window BUGS: 411587
+ FIXED-IN: 6.3.0
+
+---
+ .../generic/webservices/google/gphoto/gptalker.cpp | 3 ++-
+ core/dplugins/generic/webservices/google/gswindow.cpp | 18 ++++++++++++++----
+ 3 files changed, 17 insertions(+), 5 deletions(-)
+
+diff --git a/core/dplugins/generic/webservices/google/gphoto/gptalker.cpp b/core/dplugins/generic/webservices/google/gphoto/gptalker.cpp
+index 1cddfbd..b5e68ef 100644
+--- a/core/dplugins/generic/webservices/google/gphoto/gptalker.cpp
++++ b/core/dplugins/generic/webservices/google/gphoto/gptalker.cpp
+@@ -160,6 +160,7 @@ GPTalker::~GPTalker()
+ if (m_reply)
+ {
+ m_reply->abort();
++ m_reply = nullptr;
+ }
+
+ WSToolUtils::removeTemporaryDir("google");
+@@ -637,7 +638,7 @@ void GPTalker::slotFinished(QNetworkReply* reply)
+ {
+ emit signalAddPhotoDone(reply->error(), reply->errorString());
+ }
+- else
++ else if (reply->error() != QNetworkReply::OperationCanceledError)
+ {
+ QMessageBox::critical(QApplication::activeWindow(),
+ i18n("Error"), reply->errorString());
+diff --git a/core/dplugins/generic/webservices/google/gswindow.cpp b/core/dplugins/generic/webservices/google/gswindow.cpp
+index 424aee2..d5af448 100644
+--- a/core/dplugins/generic/webservices/google/gswindow.cpp
++++ b/core/dplugins/generic/webservices/google/gswindow.cpp
+@@ -266,11 +266,10 @@ GSWindow::GSWindow(DInfoInterface* const iface,
+
+ GSWindow::~GSWindow()
+ {
+- delete d->widget;
+- delete d->albumDlg;
+- delete d->gphotoAlbumDlg;
+- delete d->talker;
++ d->transferQueue.clear();
++
+ delete d->gphotoTalker;
++ delete d->talker;
+ delete d;
+ }
+
+@@ -851,6 +850,11 @@ void GSWindow::downloadNextPhoto()
+ void GSWindow::slotGetPhotoDone(int errCode, const QString& errMsg,
+ const QByteArray& photoData, const QString& fileName)
+ {
++ if (d->transferQueue.isEmpty())
++ {
++ return;
++ }
++
+ GSPhoto item = d->transferQueue.first().second;
+
+ /**
+@@ -982,6 +986,11 @@ void GSWindow::slotGetPhotoDone(int errCode, const QString& errMsg,
+
+ void GSWindow::slotAddPhotoDone(int err, const QString& msg)
+ {
++ if (d->transferQueue.isEmpty())
++ {
++ return;
++ }
++
+ if (err == 0)
+ {
+ d->widget->imagesList()->processed(d->transferQueue.first().first,false);
+@@ -1245,6 +1254,7 @@ void GSWindow::buttonStateChange(bool state)
+ void GSWindow::slotFinished()
+ {
+ writeSettings();
++ d->transferQueue.clear();
+ d->widget->imagesList()->listView()->clear();
+ }
+
+--
+cgit v1.1