summaryrefslogtreecommitdiff
path: root/media-gfx/dawn/dawn-3.90b-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /media-gfx/dawn/dawn-3.90b-r1.ebuild
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'media-gfx/dawn/dawn-3.90b-r1.ebuild')
-rw-r--r--media-gfx/dawn/dawn-3.90b-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-gfx/dawn/dawn-3.90b-r1.ebuild b/media-gfx/dawn/dawn-3.90b-r1.ebuild
new file mode 100644
index 000000000000..eb0d35f516dd
--- /dev/null
+++ b/media-gfx/dawn/dawn-3.90b-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver toolchain-funcs
+
+MY_P=${PN}_$(ver_rs 1 _)
+
+DESCRIPTION="3D geometrical postscript renderer"
+HOMEPAGE="http://geant4.kek.jp/~tanaka/DAWN/About_DAWN.html"
+SRC_URI="http://geant4.kek.jp/~tanaka/src/${MY_P}.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="amd64 ~hppa ~ppc ~x86"
+IUSE="doc opengl X"
+
+RDEPEND="dev-lang/tk:*
+ opengl? ( virtual/opengl )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ app-shells/tcsh
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-interactive.patch
+ "${FILESDIR}"/${P}-gcc7.patch
+)
+
+DOCS=( README.txt )
+
+src_prepare() {
+ default
+
+ sed -i -e "s/\$(LIB_DIR)/\$(LDFLAGS) &/" \
+ -e '/strip/d' Makefile*in || die
+
+ if use X; then
+ mv -f configure_xwin configure || die
+ fi
+
+ tc-export CXX
+}
+
+src_install() {
+ dodir /usr/bin
+
+ if use doc; then
+ pdflatex DOC/G4PRIM_FORMAT_24.tex || die "pdf generation failed"
+ DOCS+=( DOC/*.pdf )
+ HTML_DOCS=( DOC/*.html )
+ fi
+
+ default
+}