summaryrefslogtreecommitdiff
path: root/media-gfx/darktable/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /media-gfx/darktable/files
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'media-gfx/darktable/files')
-rw-r--r--media-gfx/darktable/files/darktable-3.4.0-xmmintrin-sse-only.patch30
-rw-r--r--media-gfx/darktable/files/darktable-3.4.0_jsonschema-automagic.patch25
2 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/darktable/files/darktable-3.4.0-xmmintrin-sse-only.patch b/media-gfx/darktable/files/darktable-3.4.0-xmmintrin-sse-only.patch
new file mode 100644
index 000000000000..2e13ad859c82
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.4.0-xmmintrin-sse-only.patch
@@ -0,0 +1,30 @@
+From d10c290fb3b47bbc8fd90d6d1d7935b900c1caf6 Mon Sep 17 00:00:00 2001
+From: Pascal Obry <pascal@obry.net>
+Date: Thu, 24 Dec 2020 16:17:19 +0100
+Subject: [PATCH] guided_filter: include xmmintrin.h only if SSE defined.
+
+Fixes #7428.
+---
+ src/common/guided_filter.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/common/guided_filter.h b/src/common/guided_filter.h
+index 36be0de04b9..59c8b2af999 100644
+--- a/src/common/guided_filter.h
++++ b/src/common/guided_filter.h
+@@ -18,6 +18,7 @@
+
+ #pragma once
+
++#if defined(__SSE__)
+ #ifdef __PPC64__
+ #ifdef NO_WARN_X86_INTRINSICS
+ #include <xmmintrin.h>
+@@ -29,6 +30,7 @@
+ #else
+ #include <xmmintrin.h>
+ #endif // __PPC64__
++#endif
+
+ #include "common/darktable.h"
+ #include "common/opencl.h"
diff --git a/media-gfx/darktable/files/darktable-3.4.0_jsonschema-automagic.patch b/media-gfx/darktable/files/darktable-3.4.0_jsonschema-automagic.patch
new file mode 100644
index 000000000000..45d61e6af6c2
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.4.0_jsonschema-automagic.patch
@@ -0,0 +1,25 @@
+jsonschema is only used at install time to validate a file that release
+tarballs already include, treat running it as a late part of tests.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -350,6 +350,9 @@
+ endif()
+
+ # we need jsonschema to check noiseprofiles.json
++# In case of Git clones this file is generated at build time, for releases
++# it is included in the tarball.
++if (WANT_JSON_VALIDATION)
+ find_program(jsonschema_BIN jsonschema)
+ if(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+ message(STATUS "Missing jsonschema, problems in noiseprofiles.json might go unnoticed")
+@@ -358,6 +361,9 @@
+ message(STATUS "Found jsonschema")
+ set(VALIDATE_JSON 1)
+ endif(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
++else()
++ set(VALIDATE_JSON 0)
++endif()
+
+ # we need an XSLT interpreter to generate preferences_gen.h and darktablerc
+ find_program(Xsltproc_BIN xsltproc)