summaryrefslogtreecommitdiff
path: root/media-gfx/curtail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 08:23:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 08:23:43 +0000
commit1826a30af36ae674cb71400eacaf0a0762df510f (patch)
tree25fc08839f1c2764daac15491280f3a6fd11d48b /media-gfx/curtail
parent3b32ae7547d742f6e65770361188670710bec186 (diff)
gentoo auto-resync : 21:02:2023 - 08:23:43
Diffstat (limited to 'media-gfx/curtail')
-rw-r--r--media-gfx/curtail/Manifest3
-rw-r--r--media-gfx/curtail/curtail-1.3.1.ebuild60
-rw-r--r--media-gfx/curtail/metadata.xml20
3 files changed, 83 insertions, 0 deletions
diff --git a/media-gfx/curtail/Manifest b/media-gfx/curtail/Manifest
new file mode 100644
index 000000000000..56229faaf11b
--- /dev/null
+++ b/media-gfx/curtail/Manifest
@@ -0,0 +1,3 @@
+DIST curtail-1.3.1.tar.gz 176042 BLAKE2B 0757c3c3eed24fea8f1493021d30df40fd8c78dad3bfd7f63cfaa83f36d36f69c47ba4e41a53a7a4299d436fb978ae3fc31afa07b5a1c9d82a6400a17c104966 SHA512 47d1b3939eaeaa3d27c497318bc80d0b7cb1c2674d66ed17c8cc5e6206b3efce7867ff01542b40ee6a4b4127160f2baed084b5b99cf518f2438dcf53af425f89
+EBUILD curtail-1.3.1.ebuild 1173 BLAKE2B 1bc7a4b07a3b48c864d1b6f92805089a291d52c2005fab104195a436f98c033ad7236c94ef96011756d9fc86ac0b3e8d460ce7fee317401d769d7d5507eb70d7 SHA512 689cc982d7ebd0bbfae301d568d9e186e9de45c56702e2bd5f686c984052334692366c04cd5ee9accbe8d7c2e5668165f0c6ae1da6f873c930d6be89c1e854ce
+MISC metadata.xml 817 BLAKE2B ea01ae4c58024699aae770d6e7f21a03adfc8da5f5f658a0b1708824bfda730a2fce4557de4fbccbc079c66a11ab08d6faef020bf897d47870f6581b5e0d68e6 SHA512 3d573feda8c750a08903203c1d2f2e1385e17242356c6f319e29944e530b2199a27e4e432a806dfe1f2c8c783dd67c4fe347d5160d4df99911f67623a3168eee
diff --git a/media-gfx/curtail/curtail-1.3.1.ebuild b/media-gfx/curtail/curtail-1.3.1.ebuild
new file mode 100644
index 000000000000..0077c4c0406c
--- /dev/null
+++ b/media-gfx/curtail/curtail-1.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Image compressor, supporting PNG, JPEG and WebP"
+HOMEPAGE="https://github.com/Huluti/Curtail/"
+SRC_URI="https://github.com/Huluti/${PN^}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P^}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test" # Just desktop / schema / appstream file validation (fails).
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3[introspection]
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+RDEPEND+="
+ media-gfx/jpegoptim
+ media-gfx/optipng
+ media-gfx/pngquant
+ media-libs/libwebp
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ sed -i "s|@PYTHON@|${PYTHON}|" "${S}"/src/${PN}.in || die
+
+ default
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/media-gfx/curtail/metadata.xml b/media-gfx/curtail/metadata.xml
new file mode 100644
index 000000000000..f46007665087
--- /dev/null
+++ b/media-gfx/curtail/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Curtail (previously ImCompressor) is an useful image compressor, supporting
+ PNG, JPEG and WebP file types. It support both lossless and lossy
+ compression modes with an option to whether keep or not metadata of images.
+ It is inspired by Trimage and Image-Optimizer.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/Huluti/Curtail/master/CHANGELOG.md</changelog>
+ <bugs-to>https://github.com/Huluti/Curtail/issues/</bugs-to>
+ <remote-id type="github">Huluti/Curtail</remote-id>
+ </upstream>
+</pkgmetadata>