summaryrefslogtreecommitdiff
path: root/media-gfx/cura/cura-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /media-gfx/cura/cura-2.6.0.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'media-gfx/cura/cura-2.6.0.ebuild')
-rw-r--r--media-gfx/cura/cura-2.6.0.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/media-gfx/cura/cura-2.6.0.ebuild b/media-gfx/cura/cura-2.6.0.ebuild
index 0f92d0ff5de6..bf9f44699fb2 100644
--- a/media-gfx/cura/cura-2.6.0.ebuild
+++ b/media-gfx/cura/cura-2.6.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
MY_PN=Cura
MY_PV=${PV/_beta}
@@ -29,7 +30,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch"
+)
+
DOCS=( README.md )
src_configure() {
@@ -53,13 +58,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}